summaryrefslogtreecommitdiff
path: root/waterfox/waterfox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'waterfox/waterfox.spec')
-rw-r--r--waterfox/waterfox.spec102
1 files changed, 77 insertions, 25 deletions
diff --git a/waterfox/waterfox.spec b/waterfox/waterfox.spec
index a0467ef..3b3e5af 100644
--- a/waterfox/waterfox.spec
+++ b/waterfox/waterfox.spec
@@ -1,7 +1,9 @@
-%global commit 8864e433baf07e995e7047e840d8f94d8f1b2496
+%global _legacy_common_support 1
+
+%global commit d5de4ec99d1d61a309d7fcd96da12488c9afe550
%global shortcommit %(c=%{commit}; echo ${c:0:7})
-%global date 20191205
-%global with_snapshot 1
+%global date 20200408
+%global with_snapshot 0
%global branch classic
@@ -27,16 +29,13 @@ ExcludeArch: armv7hl
%global system_ffi 1
%global system_cairo 0
%global system_harfbuzz 1
-# libvpx is too new for Waterfox 56
-%if 0%{?fedora} < 30
-%global system_libvpx 1
-%else
%global system_libvpx 0
-%endif
%global system_webp 1
%global system_libicu 0
%global system_jpeg 1
+%global eme 0
+
%global run_tests 0
%global hardened_build 1
@@ -45,7 +44,7 @@ ExcludeArch: armv7hl
%global build_with_clang 0
%ifnarch %{ix86} ppc64 s390x
-%global build_with_pgo 1
+%global build_with_pgo 0
%endif
%ifarch x86_64
@@ -78,7 +77,7 @@ ExcludeArch: armv7hl
# and a downgraded rust package exists
%global build_with_pinned_rust 0
%global rust_build_min_ver 1.35
-%global rust_build_min_nover 1.38
+%global rust_build_min_nover 1.40
%global default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
%global waterfox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
@@ -115,7 +114,7 @@ ExcludeArch: armv7hl
%global sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo 65536)
%endif
-%if %{branch} == "classic"
+%if "%{branch}" == "classic"
%global channel Classic
%else
%global channel Current
@@ -154,11 +153,15 @@ BuildRequires: %{scl_buildreq}
%if 0%{?rhel} >= 7
%global system_webp 0
%endif
+# added for 2020.08 because right now el8 does not have sqlite >= 3.30.1
+%if 0%{?rhel} == 8
+%global system_sqlite 0
+%endif
Summary: Waterfox Web browser
Name: waterfox
-Version: 2019.12
-Release: 13.%{branch}%{?gver}%{?dist}
+Version: 2020.08
+Release: 11%{?branch:.%{branch}}%{?gver}%{?dist}
URL: https://www.waterfox.net
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -174,6 +177,8 @@ Source0: %{vc_url}/archive/%{version}-%{branch}/%{name}-%{version}-%{bran
# rev=revision ./waterfox-FreeBSD-patches-snapshot.sh
# https://github.com/MrAlex94/Waterfox/issues/1220
Source600: https://dl.bintray.com/phantomx/tarballs/%{freebsd_root}.tar.xz
+Source601: patch-bug1321069
+Source602: patch-bug1381815
Source10: waterfox-mozconfig
Source12: bgstack15-%{name}-prefs.js
@@ -207,14 +212,11 @@ Patch224: mozilla-1170092.patch
Patch225: mozilla-1005640-accept-lang.patch
#ARM run-time patch
Patch226: rhbz-1354671.patch
-Patch230: rhbz-1497932.patch
# Firefox upstream patches
Patch402: mozilla-1196777.patch
-Patch406: mozilla-256180.patch
Patch413: mozilla-1353817.patch
Patch415: Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
-Patch416: bug1375074-save-restore-x28.patch
Patch417: mozilla-1436242.patch
Patch418: https://hg.mozilla.org/integration/autoland/raw-rev/342812d23eb9#/mozilla-1336978.patch
Patch419: https://hg.mozilla.org/mozilla-central/raw-rev/4723934741c5#/mozilla-1320560.patch
@@ -223,6 +225,7 @@ Patch420: https://hg.mozilla.org/mozilla-central/raw-rev/97dae871389b#/mo
# Upstream updates/PRs/Reverts
#Patch???: %%{vc_url}/commit/commit.patch#/%%{name}-gh-commit.patch
+Patch450: %{vc_url}/commit/26459c47f867dc1882fa7b87e32a9e8fc5e125e5.patch#/%{name}-gh-26459c4.patch
# Debian patches
Patch500: mozilla-440908.patch
@@ -416,20 +419,19 @@ This package contains results of tests executed during build.
%ifarch aarch64
%patch226 -p1 -b .1354671
%endif
-%patch230 -p1 -b .1497932
%patch402 -p1 -b .1196777
-%patch406 -p1 -b .256180
%patch413 -p1 -b .1353817
%ifarch %{arm}
%patch415 -p1 -b .mozilla-1238661
%endif
-%patch416 -p1 -b .bug1375074-save-restore-x28
%patch417 -p1 -b .mozilla-1436242
%patch418 -p1 -b .mozilla-1336978
%patch419 -p1 -b .mozilla-1320560
%patch420 -p1 -b .mozilla-1389436
+%patch450 -p1 -b .gh26459c4 -R
+
# Debian extension patch
%patch500 -p1 -b .440908
@@ -443,6 +445,7 @@ This package contains results of tests executed during build.
# Prepare FreeBSD patches
mkdir _patches
cp -p %{freebsd_root}/patch-{bug,z-bug,revert-bug}* _patches/
+cp -pf %{S:601} %{S:602} _patches/
filterdiff -x dom/svg/crashtests/crashtests.list %{freebsd_root}/patch-bug1343147 \
> _patches/patch-bug1343147
@@ -457,16 +460,20 @@ for i in 1404057 1404324 1404180 1405878 ;do
done
# 1: unneeded
-# 2: no apply
-# 3: uncertain
+# 2: unneeded
+# 3: no apply
+# 4: uncertain
for i in \
- 702179 991253 1021761 1144632 1288587 1379148 1393235 1393283 1395486 1433747 1452576 1453127 1466606 \
- 1384121 1388744 1413143 \
+ 702179 730495 991253 1021761 1144632 1288587 1379148 1393235 1393283 1393627 1395486 1396722 \
+ 1401909 1419762 1427126 1430508 1433747 1452576 1453127 1454285 1455235 1466606 1469257 \
+ 1384121 1384701 1388744 1401063 1406396 1413143 1415883 1402442 1437450 \
1447519
do
rm -f _patches/patch-bug${i}
done
+rm -f _patches/patch-z-bug1355143
+
patchcommand='patch -p0 -s -i'
for i in _patches/patch-{bug{??????,???????},revert-bug*,z-*} ;do
@@ -486,6 +493,8 @@ done
%patch36 -p2 -b .xlocale
%endif
+ln -s media/test dom/test
+
cp %{SOURCE26} .
sed -e 's|_BRANCH_|%{channel}|g' -i distribution.ini
@@ -630,6 +639,12 @@ echo "ac_add_options --enable-rust-simd" >> .mozconfig
echo "ac_add_options --disable-rust-simd" >> .mozconfig
%endif
+%if 0%{?eme}
+echo "ac_add_options --enable-eme=widevine" >> .mozconfig
+%else
+echo "ac_add_options --disable-eme" >> .mozconfig
+%endif
+
# Remove executable bit to make brp-mangle-shebangs happy.
chmod -x third_party/rust/itertools/src/lib.rs
@@ -658,7 +673,7 @@ echo "Generate big endian version of config/external/icu/data/icud58l.dat"
# Update the various config.guess to upstream release for aarch64 support
find ./ -name config.guess -exec cp /usr/lib/rpm/config.guess {} ';'
-RPM_SMP_MFLAGS_NCPUS=%(echo %{_smp_mflags} | sed 's|-j||')
+RPM_SMP_MFLAGS_NCPUS="%{?_smp_build_ncpus}%{!?_smp_build_ncpus:2}"
RPM_NCPUS=1
# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
@@ -1074,11 +1089,48 @@ fi
#---------------------------------------------------------------------
%changelog
-* Thu Dec 19 2019 B Stack <bgstack15@gmail.com> - 2019.12-13.classic
+* Wed Aug 26 2020 B Stack <bgstack15@gmail.com> - 2020.08-11.classic
- add el7 and el8 support
- repackage for stackrpms
- disable simd globally
+* Tue Aug 25 2020 Phantom X <megaphantomx at hotmail dot com> - 2020.08-1.classic
+- 2020.08
+
+* Wed Aug 05 2020 Phantom X <megaphantomx at hotmail dot com> - 2020.07.2-1.classic
+- 2020.07.2
+
+* Wed Jul 01 2020 Phantom X <megaphantomx at hotmail dot com> - 2020.07-1.classic
+- 2020.07
+
+* Thu Jun 04 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.06-1.classic
+- 2020.06
+
+* Sat May 09 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.05-1.classic
+- 2020.05
+
+* Thu Apr 09 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.04-1.classic
+- 2020.04
+
+* Wed Mar 18 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.03.1-2.classic.20200313gitf6fe91c
+- gcc 10 fix
+
+* Fri Mar 13 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.03.1-2.classic.20200313gitf6fe91c
+- 2020.03.1
+
+* Sun Feb 16 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.02-2.classic.20200213gitdf884bb
+- Disable PGO again
+
+* Fri Feb 14 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.02-1.classic.20200213gitdf884bb
+- 2020.02
+- eme optional support switch, disabled by default
+
+* Thu Jan 16 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.01-2.classic.20200110git45130a2
+- PGO crash fix try #1
+
+* Wed Jan 15 2020 Phantom X <megaphantomx at bol dot com dot br> - 2020.01-1.classic.20200110git45130a2
+- New release/snapshot
+
* Thu Dec 12 2019 Phantom X <megaphantomx at bol dot com dot br> - 2019.12-3.classic
- PGO build from COPR crashing, try to fix disabling elfhack
bgstack15