summaryrefslogtreecommitdiff
path: root/waterfox/waterfox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'waterfox/waterfox.spec')
-rw-r--r--waterfox/waterfox.spec55
1 files changed, 39 insertions, 16 deletions
diff --git a/waterfox/waterfox.spec b/waterfox/waterfox.spec
index a9be9d1..3f85188 100644
--- a/waterfox/waterfox.spec
+++ b/waterfox/waterfox.spec
@@ -1,8 +1,10 @@
-%global commit d516ab77b8af8bd8b47bcf0772d41a10180e2412
+%global commit 68014c079a1d4afa26aaad13466fcc76d0f6dcc4
%global shortcommit %(c=%{commit}; echo ${c:0:7})
-%global date 20190916
+%global date 20191016
%global with_snapshot 1
+%global branch classic
+
%global freebsd_rev 480450
%global freebsd_root %{name}-FreeBSD-patches-r%{freebsd_rev}
@@ -70,14 +72,14 @@ ExcludeArch: armv7hl
%global disable_elfhack 0
-%global build_stylo 1
+%global build_stylo 0
%global build_rust_simd 1
# Set to build with pinned rust version
# This enables stylo build when default rust version is not supported
# and a downgraded rust package exists
%global build_with_pinned_rust 0
%global rust_build_min_ver 1.35
-%global rust_build_min_nover 1.37
+%global rust_build_min_nover 1.38
%global default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
%global waterfox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
@@ -133,14 +135,12 @@ ExcludeArch: armv7hl
# https://copr-be.cloud.fedoraproject.org/results/mlampe/devtoolset-7/epel-6-$basearch/
%define scl_env %{nil}
%define scl_buildreq coreutils
-%if 0%{?el7}
+%if 0%{?rhel} == 7
%define scl_env devtoolset-7
%define scl_buildreq devtoolset-7-toolchain
%global system_nss 0
%global system_hunspell 0
%global system_libevent 0
-%global system_webp 0
-%global system_vorbis 0
%global system_sqlite 0
%global system_libvpx 0
%global build_stylo 0
@@ -150,11 +150,15 @@ ExcludeArch: armv7hl
BuildRequires: %{scl_buildreq}
%endif
%endif
+%if 0%{?rhel} >= 7
+%global system_webp 0
+%global system_vorbis 0
+%endif
Summary: Waterfox Web browser
Name: waterfox
-Version: 56.2.14
-Release: 11%{?gver}%{?dist}
+Version: 2019.10
+Release: 12.%{branch}%{?gver}%{?dist}
URL: https://www.waterfox.net
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -162,7 +166,7 @@ License: MPLv1.1 or GPLv2+ or LGPLv2+
%if 0%{?with_snapshot}
Source0: %{vc_url}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
%else
-Source0: %{vc_url}/archive/%{version}/%{name}-%{version}.tar.gz
+Source0: %{vc_url}/archive/%{version}-%{branch}/%{name}-%{version}-%{branch}.tar.gz
%endif
# FreeBSD patches
@@ -215,9 +219,13 @@ Patch418: https://hg.mozilla.org/integration/autoland/raw-rev/342812d23eb
Patch419: https://hg.mozilla.org/mozilla-central/raw-rev/4723934741c5#/mozilla-1320560.patch
Patch420: https://hg.mozilla.org/mozilla-central/raw-rev/97dae871389b#/mozilla-1389436.patch
-# Upstream updates/PRs
+# Upstream updates/PRs/Reverts
#Patch???: %%{vc_url}/commit/commit.patch#/%%{name}-gh-commit.patch
+## These seems to breaking LTO
+Patch450: %{vc_url}/commit/8f87cbc0938fec17726dd09b4af2648c084fdbf7.patch#/%{name}-gh-8f87cbc.patch
+Patch451: %{vc_url}/commit/8eacc27e9529f29dea26625ca2a28a9b9aff62c4.patch#/%{name}-gh-8eacc27.patch
+Patch452: %{vc_url}/commit/94dc86561e44725210db9491ca7a06ed0322dff6.patch#/%{name}-gh-94dc865.patch
# Debian patches
Patch500: mozilla-440908.patch
@@ -330,7 +338,9 @@ BuildRequires: nss-devel >= 3.29.1-2.1
Requires: nss >= 3.29.1-2.1
BuildRequires: desktop-file-utils
+%if 0%{?rhel} != 8
BuildRequires: system-bookmarks
+%endif
%if 0%{?system_sqlite}
BuildRequires: pkgconfig(sqlite3) >= %{sqlite_version}
Requires: sqlite >= %{sqlite_build_version}
@@ -377,7 +387,7 @@ This package contains results of tests executed during build.
%if 0%{?with_snapshot}
%setup -q -n Waterfox-%{commit} -a 600
%else
-%setup -q -n Waterfox-%{version} -a 600
+%setup -q -n Waterfox-%{version}-%{branch} -a 600
%endif
%if %{build_langpacks}
@@ -429,6 +439,10 @@ This package contains results of tests executed during build.
%patch419 -p1 -b .mozilla-1320560
%patch420 -p1 -b .mozilla-1389436
+%patch450 -p1 -R
+%patch451 -p1 -R
+%patch452 -p1 -R
+
# Debian extension patch
%patch500 -p1 -b .440908
@@ -459,7 +473,7 @@ done
# 2: no apply
# 3: uncertain
for i in \
- 702179 991253 1021761 1144632 1288587 1393235 1393283 1395486 1433747 1452576 1453127 1466606 \
+ 702179 991253 1021761 1144632 1288587 1379148 1393235 1393283 1395486 1433747 1452576 1453127 1466606 \
1384121 1388744 1413143 \
1447519
do
@@ -834,8 +848,10 @@ rm -f objdir/dist/bin/pk12util
pushd $thispwd
%endif
+%if ! 0%{?rhel} >= 8
# set up our default bookmarks
cp -p %{default_bookmarks_file} objdir/dist/bin/browser/chrome/en-US/locale/browser/bookmarks.html
+%endif
# Make sure locale works for langpacks
cat > objdir/dist/bin/browser/defaults/preferences/firefox-l10n.js << EOF
@@ -1033,7 +1049,6 @@ fi
# That's Windows only
%ghost %{mozappdir}/browser/features/aushelper@mozilla.org.xpi
%attr(644, root, root) %{mozappdir}/browser/blocklist.xml
-%attr(644, root, root) %{mozappdir}/browser/ua-update.json
%dir %{mozappdir}/browser/extensions
%{mozappdir}/browser/extensions/*
%if %{build_langpacks}
@@ -1068,10 +1083,18 @@ fi
#---------------------------------------------------------------------
%changelog
-* Fri Sep 20 2019 B Stack <bgstack15@gmail.com> - 56.2.14-12.20190916gitd516ab7
-- add el7 support, which uses provided libs for the most part, and disables lto
+* Thu Oct 17 2019 B Stack <bgstack15@gmail.com> - 2019.10-12.classic.20191016git68014c0
+- add el7 and el8 support
- repackage for stackrpms
+* Wed Oct 16 2019 Phantom X <megaphantomx at bol dot com dot br> - 2019.10-2.classic.20191016git68014c0
+- Try to fix crash with LTO, reverting some commits
+
+* Wed Oct 16 2019 Phantom X <megaphantomx at bol dot com dot br> - 2019.10-1.classic
+- 2019.10-classic
+- Enable av1
+- Disable stylo, rust 1.38 build error
+
* Wed Sep 18 2019 Phantom X <megaphantomx at bol dot com dot br> - 56.2.14-2.20190916gitd516ab7
- New snapshot
bgstack15