summaryrefslogtreecommitdiff
path: root/veracrypt/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'veracrypt/debian/patches')
-rw-r--r--veracrypt/debian/patches/001-user-guide-location.diff22
-rw-r--r--veracrypt/debian/patches/002-build-flags.diff34
-rw-r--r--veracrypt/debian/patches/004-fixup-install.diff52
-rw-r--r--veracrypt/debian/patches/series4
-rw-r--r--veracrypt/debian/patches/vc_devuan.patch35
5 files changed, 147 insertions, 0 deletions
diff --git a/veracrypt/debian/patches/001-user-guide-location.diff b/veracrypt/debian/patches/001-user-guide-location.diff
new file mode 100644
index 0000000..e7bddf2
--- /dev/null
+++ b/veracrypt/debian/patches/001-user-guide-location.diff
@@ -0,0 +1,22 @@
+From: Francis Russell <francis@unchartedbackwaters.co.uk>
+Date: Mon, 14 Jan 2013 11:44
+Subject: Move manual
+
+The user manual is installed in /usr/share/doc/veracrypt as opposed to
+/usr/share/veracrypt/doc.
+
+Forwarded: no
+
+Index: veracrypt/src/Main/GraphicUserInterface.cpp
+===================================================================
+--- a/src/Main/GraphicUserInterface.cpp 2017-06-29 17:10:39.000000000 -0400
++++ b/src/Main/GraphicUserInterface.cpp 2017-06-30 16:30:20.842509262 -0400
+@@ -1309,7 +1309,7 @@
+ #elif defined (TC_MACOSX)
+ htmlPath += L"/../Resources/doc/HTML/";
+ #elif defined (TC_UNIX)
+- htmlPath = L"/usr/share/veracrypt/doc/HTML/";
++ htmlPath = L"/usr/share/doc/veracrypt/HTML/";
+ #else
+ localFile = false;
+ #endif
diff --git a/veracrypt/debian/patches/002-build-flags.diff b/veracrypt/debian/patches/002-build-flags.diff
new file mode 100644
index 0000000..20c8362
--- /dev/null
+++ b/veracrypt/debian/patches/002-build-flags.diff
@@ -0,0 +1,34 @@
+From: Stefan Sundin <stefan@stefansundin.com>
+Date: Fri, 12 Sept 2013
+Subject: Add build flags
+
+Forwarded: no
+
+Index: veracrypt/src/Makefile
+===================================================================
+--- veracrypt.orig/src/Makefile
++++ veracrypt/src/Makefile
+@@ -57,6 +57,10 @@ export WXCONFIG_CFLAGS :=
+ export WXCONFIG_CXXFLAGS :=
+ WX_ROOT ?= ..
+
++CPPFLAGS+=$(shell dpkg-buildflags --get CPPFLAGS)
++CFLAGS+=$(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS) -Wno-sequence-point
++CXXFLAGS+=$(shell dpkg-buildflags --get CXXFLAGS) $(CPPFLAGS) -Wno-narrowing
++LFLAGS+=$(shell dpkg-buildflags --get LDFLAGS)
+
+ export TC_BUILD_CONFIG := Release
+
+Index: veracrypt/src/Build/Include/Makefile.inc
+===================================================================
+--- veracrypt.orig/src/Build/Include/Makefile.inc
++++ veracrypt/src/Build/Include/Makefile.inc
+@@ -14,7 +14,7 @@ $(NAME): $(NAME).a
+
+ clean:
+ @echo Cleaning $(NAME)
+- rm -f $(APPNAME) $(NAME).a $(OBJS) $(OBJSEX) $(OBJS:.o=.d) *.gch
++ rm -f $(APPNAME) $(NAME).a $(OBJS) $(OBJS:.o=.d) *.gch $(RESOURCES) SystemPrecompiled.d
+
+ %.o: %.c
+ @echo Compiling $(<F)
diff --git a/veracrypt/debian/patches/004-fixup-install.diff b/veracrypt/debian/patches/004-fixup-install.diff
new file mode 100644
index 0000000..8257d10
--- /dev/null
+++ b/veracrypt/debian/patches/004-fixup-install.diff
@@ -0,0 +1,52 @@
+Description: Fixup the install target so it's usable.
+ - Use a path that works from the top src dir.
+ - Inverse 'doc' and 'veracrypt' in /usr/share/veracrypt/doc/
+ - Don't install the uninstall script nor extra License.txt file.
+ - Use our own veracrypt.desktop file.
+Author: Unit 193 <unit193@ubuntu.com>
+
+Origin: vendor
+Forwarded: no
+Last-Update: 2017-07-10
+
+--- veracrypt-1.21.orig/src/Main/Main.make
++++ veracrypt-1.21/src/Main/Main.make
+@@ -236,25 +236,25 @@ endif
+
+ ifeq "$(PLATFORM)" "Linux"
+ prepare: $(APPNAME)
+- rm -fr $(PWD)/Setup/Linux/usr
+- mkdir -p $(PWD)/Setup/Linux/usr/bin
+- mkdir -p $(PWD)/Setup/Linux/usr/share/$(APPNAME)/doc/HTML
+- cp $(PWD)/Main/$(APPNAME) $(PWD)/Setup/Linux/usr/bin/$(APPNAME)
+- cp $(PWD)/Setup/Linux/$(APPNAME)-uninstall.sh $(PWD)/Setup/Linux/usr/bin/$(APPNAME)-uninstall.sh
+- chmod +x $(PWD)/Setup/Linux/usr/bin/$(APPNAME)-uninstall.sh
+- cp $(PWD)/License.txt $(PWD)/Setup/Linux/usr/share/$(APPNAME)/doc/License.txt
+- cp $(PWD)/../doc/html/* "$(PWD)/Setup/Linux/usr/share/$(APPNAME)/doc/HTML"
++ rm -fr $(CURDIR)/../Setup/Linux/usr
++ mkdir -p $(CURDIR)/../Setup/Linux/usr/bin
++ mkdir -p $(CURDIR)/../Setup/Linux/usr/share/doc/$(APPNAME)/HTML
++ cp $(CURDIR)/$(APPNAME) $(CURDIR)/../Setup/Linux/usr/bin/$(APPNAME)
++# cp $(CURDIR)/../Setup/Linux/$(APPNAME)-uninstall.sh $(CURDIR)/../Setup/Linux/usr/bin/$(APPNAME)-uninstall.sh
++# chmod +x $(CURDIR)/../Setup/Linux/usr/bin/$(APPNAME)-uninstall.sh
++# cp $(CURDIR)/../License.txt $(CURDIR)/../Setup/Linux/usr/share/doc/$(APPNAME)/License.txt
++ cp $(CURDIR)/../../doc/html/* "$(CURDIR)/../Setup/Linux/usr/share/doc/$(APPNAME)/HTML"
+
+ ifndef TC_NO_GUI
+- mkdir -p $(PWD)/Setup/Linux/usr/share/applications
+- mkdir -p $(PWD)/Setup/Linux/usr/share/pixmaps
+- cp $(PWD)/Resources/Icons/VeraCrypt-256x256.xpm $(PWD)/Setup/Linux/usr/share/pixmaps/$(APPNAME).xpm
+- cp $(PWD)/Setup/Linux/$(APPNAME).desktop $(PWD)/Setup/Linux/usr/share/applications/$(APPNAME).desktop
++# mkdir -p $(CURDIR)/../Setup/Linux/usr/share/applications
++ mkdir -p $(CURDIR)/../Setup/Linux/usr/share/pixmaps
++ cp $(CURDIR)/../Resources/Icons/VeraCrypt-256x256.xpm $(CURDIR)/../Setup/Linux/usr/share/pixmaps/$(APPNAME).xpm
++# cp $(CURDIR)/../Setup/Linux/$(APPNAME).desktop $(CURDIR)/../Setup/Linux/usr/share/applications/$(APPNAME).desktop
+ endif
+
+
+ install: prepare
+- cp -R $(CURDIR)/Setup/Linux/usr $(DESTDIR)/.
++ cp -R $(CURDIR)/../Setup/Linux/usr $(DESTDIR)/
+
+ ifeq "$(TC_BUILD_CONFIG)" "Release"
+ package: prepare
diff --git a/veracrypt/debian/patches/series b/veracrypt/debian/patches/series
new file mode 100644
index 0000000..5f788f9
--- /dev/null
+++ b/veracrypt/debian/patches/series
@@ -0,0 +1,4 @@
+001-user-guide-location.diff
+002-build-flags.diff
+004-fixup-install.diff
+vc_devuan.patch
diff --git a/veracrypt/debian/patches/vc_devuan.patch b/veracrypt/debian/patches/vc_devuan.patch
new file mode 100644
index 0000000..b55bea5
--- /dev/null
+++ b/veracrypt/debian/patches/vc_devuan.patch
@@ -0,0 +1,35 @@
+diff -x '*.rej' -x '*.orig' -Naur VeraCrypt_1.22/src/Common/Dlgcode.c VeraCrypt_1.22-1/src/Common/Dlgcode.c
+--- VeraCrypt_1.22/src/Common/Dlgcode.c 2018-03-30 07:54:10.000000000 -0400
++++ VeraCrypt_1.22-1/src/Common/Dlgcode.c 2018-09-02 08:22:00.007030589 -0400
+@@ -1280,7 +1280,7 @@
+ L"This software as a whole:\r\n"
+ L"Copyright \xA9 2013-2018 IDRIX. All rights reserved.\r\n\r\n"
+
+- L"An IDRIX Release");
++ L"Packaged for Devuan");
+
+ return 1;
+
+diff -x '*.rej' -x '*.orig' -Naur VeraCrypt_1.22/src/Common/Tcdefs.h VeraCrypt_1.22-1/src/Common/Tcdefs.h
+--- VeraCrypt_1.22/src/Common/Tcdefs.h 2018-03-30 07:54:10.000000000 -0400
++++ VeraCrypt_1.22-1/src/Common/Tcdefs.h 2018-09-02 08:23:02.200707158 -0400
+@@ -383,7 +383,7 @@
+ #define TC_MAX_PATH 260 /* Includes the null terminator */
+ #endif
+
+-#define TC_STR_RELEASED_BY L"Released by IDRIX on " TC_STR_RELEASE_DATE
++#define TC_STR_RELEASED_BY L"Published for Devuan using IDRIX build " TC_STR_RELEASE_DATE
+
+ #define MAX_URL_LENGTH 2084 /* Internet Explorer limit. Includes the terminating null character. */
+
+diff -x '*.rej' -x '*.orig' -Naur VeraCrypt_1.22/src/Main/Forms/AboutDialog.cpp VeraCrypt_1.22-1/src/Main/Forms/AboutDialog.cpp
+--- VeraCrypt_1.22/src/Main/Forms/AboutDialog.cpp 2018-03-30 07:54:10.000000000 -0400
++++ VeraCrypt_1.22-1/src/Main/Forms/AboutDialog.cpp 2018-09-02 08:23:41.447134097 -0400
+@@ -72,6 +72,6 @@
+
+ L"This software uses wxWidgets library, which is copyright \xA9 1998-2011 Julian Smart, Robert Roebling et al.\n\n"
+
+- L"An IDRIX Release");
++ L"Packaged for Devuan");
+ }
+ }
bgstack15