summaryrefslogtreecommitdiff
path: root/simple-mtpfs/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'simple-mtpfs/debian/rules')
-rwxr-xr-xsimple-mtpfs/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/simple-mtpfs/debian/rules b/simple-mtpfs/debian/rules
new file mode 100755
index 0000000..ec34512
--- /dev/null
+++ b/simple-mtpfs/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+# minimise needless linking
+export DEB_LDFLAGS_MAINT_APPEND= -Wl,--as-needed
+
+%:
+ dh $@ --parallel --with autoreconf
+
+# use --as-needed only if supported by dh-autoreconf (to simplify backporting)
+DH_AS_NEEDED=$(shell dpkg --compare-versions $$(dpkg --status dh-autoreconf | grep Version | cut -d' ' -f2) ge 6 && echo --as-needed)
+override_dh_autoreconf:
+ [ ! -x "./autogen.sh" ] || ./autogen.sh
+ dh_autoreconf $(DH_AS_NEEDED)
bgstack15