summaryrefslogtreecommitdiff
path: root/scite-fedora/scite.spec
diff options
context:
space:
mode:
Diffstat (limited to 'scite-fedora/scite.spec')
-rw-r--r--scite-fedora/scite.spec41
1 files changed, 32 insertions, 9 deletions
diff --git a/scite-fedora/scite.spec b/scite-fedora/scite.spec
index b80a183..9c62f6a 100644
--- a/scite-fedora/scite.spec
+++ b/scite-fedora/scite.spec
@@ -1,5 +1,5 @@
# el is on 3.x, fc is on 4.x
-%global pkgversion 4.2.2
+%global pkgversion 4.4.4
%define tarballversion %( echo %pkgversion | tr -d '.' )
%define scl_env %{nil}
@@ -48,24 +48,28 @@ rm -rf scite/lua
%if "%{?scl_env}" != ""
scl enable %{scl_env} /bin/bash <<'EOFSCL'
%endif
- make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags}" \
- CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" DEBUG=1 -C scintilla/gtk
+ make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags} -shared -dynamiclib" \
+ CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" DEBUG=1 -C scintilla/gtk \
+ libdir=%{_libdir}
#Build without lua support
make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags}" \
- CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" DEBUG=1 NO_LUA=1 -C scite/gtk
+ CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" DEBUG=1 NO_LUA=1 -C scite/gtk \
+ libdir=%{_libdir}
%if "%{?scl_env}" != ""
EOFSCL
%endif
%else
- make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags}" \
- CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" GTK3=1 DEBUG=1 -C scintilla/gtk
+ make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags} -shared -dynamiclib" \
+ CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" GTK3=1 DEBUG=1 -C scintilla/gtk \
+ libdir=%{_libdir}
#Build without lua support
make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags}" \
- CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" GTK3=1 DEBUG=1 NO_LUA=1 -C scite/gtk
+ CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" GTK3=1 DEBUG=1 NO_LUA=1 -C scite/gtk \
+ libdir=%{_libdir}
%endif
%install
-make DESTDIR=%{buildroot} -C scite/gtk install
+make DESTDIR=%{buildroot} -C scite/gtk install libdir=%{_libdir}
ln -s SciTE %{buildroot}%{_bindir}/scite
# include man-page
@@ -96,15 +100,34 @@ desktop-file-install --delete-original \
%{_datadir}/scite/
%{_datadir}/pixmaps/*
%{_datadir}/applications/*
+%{_libdir}/*
%changelog
+* Thu Jul 23 2020 B Stack <bgstack15@gmail.com> - 4.4.4-1/3.7.6-1
+- Update version
+
+* Wed Jun 03 2020 B Stack <bgstack15@gmail.com> - 4.4.3-1/3.7.6-1
+- Update version
+
+* Tue May 05 2020 B Stack <bgstack15@gmail.com> - 4.3.3-1/3.7.6-1
+- Update version
+
+* Wed Mar 04 2020 B Stack <bgstack15@gmail.com> - 4.3.1-1/3.7.6-1
+- Update version
+
+* Thu Jan 16 2020 B Stack <bgstack15@gmail.com> - 4.3.0-1/3.7.6-1
+- Update version
+
+* Thu Dec 19 2019 B Stack <bgstack15@gmail.com> - 4.2.3-1/3.7.6-1
+- Update version
+
* Mon Nov 11 2019 B Stack <bgstack15@gmail.com> - 4.2.2-1/3.7.6-1
- Update version
* Mon Nov 11 2019 B Stack <bgstack15@gmail.com> - 4.2.1-1/3.7.6-1
- Rewritten to build Fedora and Enterprise Linux versions from a single spec with minor flags changed
-* Tue Jun 6 2019 B Stack <bgstack15@gmail.com> - 4.1.6-1/3.7.5-1
+* Thu Jun 6 2019 B Stack <bgstack15@gmail.com> - 4.1.6-1/3.7.5-1
- Rewritten to build Fedora and Enterprise Linux versions from a single spec with minor flags changed
* Mon May 6 2019 B Stack <bgstack15@gmail.com> - 4.1.5-1
bgstack15