summaryrefslogtreecommitdiff
path: root/scite-fedora/scite.spec
diff options
context:
space:
mode:
Diffstat (limited to 'scite-fedora/scite.spec')
-rw-r--r--scite-fedora/scite.spec37
1 files changed, 23 insertions, 14 deletions
diff --git a/scite-fedora/scite.spec b/scite-fedora/scite.spec
index 7de17a7..4b4f8d3 100644
--- a/scite-fedora/scite.spec
+++ b/scite-fedora/scite.spec
@@ -1,5 +1,5 @@
-# el is on 3.x, fc is on 4.x
-%global pkgversion 4.4.5
+# el is on 3.x, fc is on 5.x
+%global pkgversion 5.0.1
%define tarballversion %( echo %pkgversion | tr -d '.' )
%define scl_env %{nil}
@@ -16,7 +16,7 @@ Summary: SCIntilla-based GTK text editor
License: MIT
Group: Applications/Editors
Url: http://www.scintilla.org/SciTE.html
-Packager: B Stack <bgstack15@gmail.com>
+Packager: B. Stack <bgstack15@gmail.com>
Source0: https://www.scintilla.org/scite%{tarballversion}.tgz
Patch0: scite-utf8.patch
@@ -49,6 +49,9 @@ rm -rf scite/lua
scl enable %{scl_env} /bin/bash <<'EOFSCL'
%endif
make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags} -shared -dynamiclib" \
+ CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" DEBUG=1 -C lexilla/src \
+ libdir=%{_libdir}
+ make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags} -shared -dynamiclib" \
CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" DEBUG=1 -C scintilla/gtk \
libdir=%{_libdir}
#Build without lua support
@@ -60,6 +63,9 @@ EOFSCL
%endif
%else
make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags} -shared -dynamiclib" \
+ CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" GTK3=1 DEBUG=1 -C lexilla/src \
+ libdir=%{_libdir}
+ make %{?_smp_mflags} LDFLAGS="%{?__global_ldflags} -shared -dynamiclib" \
CFLAGS="%{optflags}" CXXFLAGS="%{optflags}" GTK3=1 DEBUG=1 -C scintilla/gtk \
libdir=%{_libdir}
#Build without lua support
@@ -103,37 +109,40 @@ desktop-file-install --delete-original \
%{_libdir}/*
%changelog
-* Thu Oct 01 2020 B Stack <bgstack15@gmail.com> - 4.4.5-1/3.7.6-1
+* Tue Apr 20 2021 B. Stack <bgstack15@gmail.com> - 5.0.1-1/3.7.6-1
+- Update version
+
+* Thu Oct 01 2020 B. Stack <bgstack15@gmail.com> - 4.4.5-1/3.7.6-1
- Update version
-* Thu Jul 23 2020 B Stack <bgstack15@gmail.com> - 4.4.4-1/3.7.6-1
+* Thu Jul 23 2020 B. Stack <bgstack15@gmail.com> - 4.4.4-1/3.7.6-1
- Update version
-* Wed Jun 03 2020 B Stack <bgstack15@gmail.com> - 4.4.3-1/3.7.6-1
+* Wed Jun 03 2020 B. Stack <bgstack15@gmail.com> - 4.4.3-1/3.7.6-1
- Update version
-* Tue May 05 2020 B Stack <bgstack15@gmail.com> - 4.3.3-1/3.7.6-1
+* Tue May 05 2020 B. Stack <bgstack15@gmail.com> - 4.3.3-1/3.7.6-1
- Update version
-* Wed Mar 04 2020 B Stack <bgstack15@gmail.com> - 4.3.1-1/3.7.6-1
+* Wed Mar 04 2020 B. Stack <bgstack15@gmail.com> - 4.3.1-1/3.7.6-1
- Update version
-* Thu Jan 16 2020 B Stack <bgstack15@gmail.com> - 4.3.0-1/3.7.6-1
+* Thu Jan 16 2020 B. Stack <bgstack15@gmail.com> - 4.3.0-1/3.7.6-1
- Update version
-* Thu Dec 19 2019 B Stack <bgstack15@gmail.com> - 4.2.3-1/3.7.6-1
+* Thu Dec 19 2019 B. Stack <bgstack15@gmail.com> - 4.2.3-1/3.7.6-1
- Update version
-* Mon Nov 11 2019 B Stack <bgstack15@gmail.com> - 4.2.2-1/3.7.6-1
+* Mon Nov 11 2019 B. Stack <bgstack15@gmail.com> - 4.2.2-1/3.7.6-1
- Update version
-* Mon Nov 11 2019 B Stack <bgstack15@gmail.com> - 4.2.1-1/3.7.6-1
+* Mon Nov 11 2019 B. Stack <bgstack15@gmail.com> - 4.2.1-1/3.7.6-1
- Rewritten to build Fedora and Enterprise Linux versions from a single spec with minor flags changed
-* Thu Jun 6 2019 B Stack <bgstack15@gmail.com> - 4.1.6-1/3.7.5-1
+* Thu Jun 6 2019 B. Stack <bgstack15@gmail.com> - 4.1.6-1/3.7.5-1
- Rewritten to build Fedora and Enterprise Linux versions from a single spec with minor flags changed
-* Mon May 6 2019 B Stack <bgstack15@gmail.com> - 4.1.5-1
+* Mon May 6 2019 B. Stack <bgstack15@gmail.com> - 4.1.5-1
- Brought to latest version
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.5-3
bgstack15