summaryrefslogtreecommitdiff
path: root/puddletag/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'puddletag/debian/rules')
-rwxr-xr-xpuddletag/debian/rules26
1 files changed, 17 insertions, 9 deletions
diff --git a/puddletag/debian/rules b/puddletag/debian/rules
index 97b84e7..42976fb 100755
--- a/puddletag/debian/rules
+++ b/puddletag/debian/rules
@@ -8,24 +8,32 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-export PYBUILD_NAME=puddletag
-export PYBUILD_SYSTEM=distutils
+# Using pybuild causes build failures. Omitting pybuild throws tons of lintian warnings but it builds.
+#export PYBUILD_NAME=puddletag
+#export PYBUILD_SYSTEM=distutils
+# ON DH INVOCATION: --buildsystem=pybuild
%:
- dh $@ --with python3 --buildsystem=pybuild
+ dh $@ --with python3,sphinxdoc
override_dh_clean:
- dh_clean || :
-
-override_dh_auto_clean:
- dh_auto_clean || :
+ dh_clean
+ $(MAKE) -C puddletag-docs clean
override_dh_auto_install:
cd $(CURDIR)/source ; \
python3 setup.py install --root=$(CURDIR)/debian/puddletag --install-layout=deb
+ $(MAKE) -C puddletag-docs documentation SPHINXBUILD=sphinx-build
+
+override_dh_installdocs:
+ dh_installdocs README.rst source/THANKS source/TODO
+ mv puddletag-docs/_build/documentation/ puddletag-docs/_build/html/
+ dh_installdocs puddletag-docs/_build/html/
+ dh_link /usr/share/doc/puddletag/html/docs.html /usr/share/doc/puddletag/html/index.html
+
override_dh_compress:
dh_compress -X.txt
-#override_dh_installchangelogs:
-# dh_installchangelogs source/changelog
+override_dh_installchangelogs:
+ dh_installchangelogs source/changelog
bgstack15