summaryrefslogtreecommitdiff
path: root/puddletag/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'puddletag/debian/rules')
-rwxr-xr-xpuddletag/debian/rules35
1 files changed, 35 insertions, 0 deletions
diff --git a/puddletag/debian/rules b/puddletag/debian/rules
new file mode 100755
index 0000000..f253703
--- /dev/null
+++ b/puddletag/debian/rules
@@ -0,0 +1,35 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+%:
+ dh $@ --with python3,sphinxdoc
+
+override_dh_clean:
+ dh_clean
+ $(MAKE) -C puddletag-docs clean
+
+override_dh_auto_install:
+ cd $(CURDIR)/source ; \
+ python3 setup.py install --root=$(CURDIR)/debian/puddletag-py3 --install-layout=deb
+
+ $(MAKE) -C puddletag-docs documentation SPHINXBUILD=sphinx-build
+
+override_dh_installdocs:
+ dh_installdocs README.rst source/THANKS source/TODO
+ mv puddletag-docs/_build/documentation/ puddletag-docs/_build/html/
+ dh_installdocs puddletag-docs/_build/html/
+ dh_link /usr/share/doc/puddletag/html/docs.html /usr/share/doc/puddletag/html/index.html
+
+override_dh_compress:
+ dh_compress -X.txt
+
+override_dh_installchangelogs:
+ dh_installchangelogs source/changelog
bgstack15