summaryrefslogtreecommitdiff
path: root/palemoon/palemoon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'palemoon/palemoon.spec')
-rw-r--r--palemoon/palemoon.spec32
1 files changed, 20 insertions, 12 deletions
diff --git a/palemoon/palemoon.spec b/palemoon/palemoon.spec
index 6a81708..cfe3639 100644
--- a/palemoon/palemoon.spec
+++ b/palemoon/palemoon.spec
@@ -1,8 +1,11 @@
-%global tarballdir UXP-PM%{version}_Release
+%global tarballdir Pale-Moon-%{version}_Release
%global dummy_package 0
%global appname palemoon
%global prettyname Pale Moon Web Browser
%global stackrpms_custom 1
+# derive from inside the full source tree:
+# git submodule | awk -v "name=platform" '$2 == name {gsub("-","",$1); print $1}'
+%global submodule_platform_commit 41e5925b4271c598601fdc77238bbf6497576594
# additional repos to get python27 and devtoolset-7
# for el6 and el7: Software Collection;, for x86_64 only
@@ -40,18 +43,19 @@ Summary: Pale Moon web browser with stackrpms prefs
Name: palemoon
Summary: Pale Moon web browser
%endif
-Version: 28.8.4
+Version: 28.9.0.2
Release: 1
Group: Networking/Web
License: MPLv2.0
URL: http://linux.palemoon.org/
-Source0: https://github.com/MoonchildProductions/UXP/archive/PM%{version}_Release.tar.gz
-Source1: palemoon-mozconfig
-Source2: palemoon.desktop
-Source3: palemoon-mimeinfo.xml
+Source0: https://github.com/MoonchildProductions/Pale-Moon/archive/%{version}_Release.tar.gz
+Source1: https://github.com/MoonchildProductions/UXP/archive/%{submodule_platform_commit}.tar.gz
+Source2: palemoon-mozconfig
+Source3: palemoon.desktop
+Source4: palemoon-mimeinfo.xml
%if 0%{stackrpms_custom}
-Source4: bgstack15-palemoon-prefs.js
+Source5: bgstack15-palemoon-prefs.js
Patch0: small-icons.patch
Patch1: bgstack15-palemoon.patch
%endif
@@ -108,7 +112,8 @@ and themes to make the browser truly your own.
%prep
%setup -q -n %{tarballdir}
-%{__cp} %{SOURCE1} ./.mozconfig
+tar -C platform --strip-components=1 -zxf %{SOURCE1} # git submodule
+%{__cp} %{SOURCE2} ./.mozconfig
%if 0%{?fedora} >= 30
sed -i -r -e '/enable-optimize/s/"\s*$/ -Wno-format-overflow"/' ./.mozconfig
%endif
@@ -166,7 +171,7 @@ EOF
# desktop files
%{__mkdir_p} %{buildroot}%{_datadir}/applications
-desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE2}
+desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE3}
%{__sed} -i -r -e "s/@NAME@/%{prettyname}/;" \
-e "s/@EXEC@/%{appname}/;" \
@@ -180,7 +185,7 @@ desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE2}
# none
# mimetypes
-%{__install} -Dm0644 %{SOURCE3} \
+%{__install} -Dm0644 %{SOURCE4} \
%{buildroot}%{_datadir}/mime/packages/%{name}.xml
# icons
@@ -188,7 +193,7 @@ desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE2}
for s in 16 22 24 32 48 256 ;
do
%{__mkdir_p} %{buildroot}%{_datadir}/icons/hicolor/${s}x${s}/apps
- %{__cp} -p application/%{appname}/branding/official/default${s}.png \
+ %{__cp} -p %{appname}/branding/official/default${s}.png \
%{buildroot}%{_datadir}/icons/hicolor/${s}x${s}/apps/%{appname}.png
done
@@ -245,7 +250,7 @@ filelist() {
%if 0%{stackrpms_custom}
%{__install} -d %{buildroot}%{_libdir}/%{name}/browser/defaults/preferences/
-%{__install} -Dm0644 %{SOURCE4} \
+%{__install} -Dm0644 %{SOURCE5} \
%{buildroot}%{_libdir}/%{name}/browser/defaults/preferences/
%endif
@@ -279,6 +284,9 @@ update-mime-database -n ${_datadir}/mime 1>/dev/null 2>&1 & :
%doc AUTHORS LICENSE
%changelog
+* Thu Mar 26 2020 B Stack <bgstack15@gmail.com> - 28.9.0.2-1
+- update version
+
* Mon Mar 02 2020 B Stack <bgstack15@gmail.com> - 28.8.4-1
- update version
bgstack15