summaryrefslogtreecommitdiff
path: root/palemoon/palemoon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'palemoon/palemoon.spec')
-rw-r--r--palemoon/palemoon.spec17
1 files changed, 17 insertions, 0 deletions
diff --git a/palemoon/palemoon.spec b/palemoon/palemoon.spec
index 59a0c69..0a8208b 100644
--- a/palemoon/palemoon.spec
+++ b/palemoon/palemoon.spec
@@ -2,6 +2,7 @@
%global dummy_package 0
%global pkgname palemoon
%global prettyname Pale Moon Web Browser
+%global stackrpms_custom 1
# additional repos to get python27 and devtoolset-7
# for el6 and el7: Software Collection;, for x86_64 only
@@ -38,6 +39,10 @@ Source0: https://github.com/MoonchildProductions/UXP/archive/PM%{version}_Releas
Source1: palemoon-mozconfig
Source2: palemoon.desktop
Source3: palemoon-mimeinfo.xml
+%if 0%{stackrpms_custom}
+Source4: bgstack15-prefs.js
+Patch0: small-icons.patch
+%endif
Packager: Bgstack15 <bgstack15@gmail.com>
%if "%{?scl_env}" != ""
@@ -84,6 +89,12 @@ and themes to make the browser truly your own.
%setup -q -n %{tarballdir}
%{__cp} %{SOURCE1} ./.mozconfig
+%if 0%{stackrpms_custom}
+echo please find file browser.xul for the patch -pNUM
+/bin/bash
+%patch0
+%endif
+
%build
%if "%{?scl_env}" != ""
thispwd=$( pwd )
@@ -204,6 +215,12 @@ filelist() {
popd
}
+%if 0%{stackrpms_custom}
+# use /usr/lib hardcoded because that is how palemoon uses it
+%{__install} -Dm0644 %{SOURCE4} \
+ %{buildroot}%{_prefix}/lib/%{pkgname}/browser/defaults/preferences/
+%endif
+
filelist file.lst %{pkgname} usr langpack
%clean
bgstack15