summaryrefslogtreecommitdiff
path: root/openssl-freefilesync/openssl.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openssl-freefilesync/openssl.spec')
-rw-r--r--openssl-freefilesync/openssl.spec12
1 files changed, 11 insertions, 1 deletions
diff --git a/openssl-freefilesync/openssl.spec b/openssl-freefilesync/openssl.spec
index 2e23c2c..6815465 100644
--- a/openssl-freefilesync/openssl.spec
+++ b/openssl-freefilesync/openssl.spec
@@ -16,6 +16,7 @@
# for openssl-freefilesync
%define fullname openssl-freefilesync
%define shortname openssl
+%define suffix 111c
# Arches on which we need to prevent arch conflicts on opensslconf.h, must
# also be handled in opensslconf-new.h.
@@ -406,13 +407,22 @@ install -m644 %{SOURCE9} \
LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
export LD_LIBRARY_PATH
+# for openssl-freefilesync
+pushd ${RPM_BUILD_ROOT}%{_mandir}
+for word in $( find . ! -type d -print ) ;
+do
+ mv "${word}" "${word}%{suffix}"
+done
+popd
+mv %{RPM_BUILD_ROOT}%{_bindir}/openssl{,%{suffix}}
+
%files
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc FAQ NEWS README README.FIPS
%{_bindir}/make-dummy-cert
%{_bindir}/renew-dummy-cert
-%{_bindir}/openssl
+%{_bindir}/openssl%{suffix}
%{_mandir}/man1*/*
%{_mandir}/man5*/*
%{_mandir}/man7*/*
bgstack15