summaryrefslogtreecommitdiff
path: root/newmoon/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'newmoon/debian/rules')
-rwxr-xr-xnewmoon/debian/rules47
1 files changed, 47 insertions, 0 deletions
diff --git a/newmoon/debian/rules b/newmoon/debian/rules
new file mode 100755
index 0000000..db92cdd
--- /dev/null
+++ b/newmoon/debian/rules
@@ -0,0 +1,47 @@
+#!/usr/bin/make -f
+
+export SHELL=/bin/bash
+
+## borrowed from stevepusser's logic
+## Build with gcc-8 on Buster (beowulf/ceres)
+## If you enable this, then d/control needs lsb-release as a build dependency.
+#distrelease := $(shell lsb_release -cs)
+#ifeq ($(distrelease),$(filter $(distrelease),buster beowulf/ceres))
+#export CC=gcc-8
+#export CXX=g++-8
+#export CPP=cpp-8
+#export LD=gcc-8
+#endif
+
+export MCFILE=debian/mozconfig
+
+%:
+ dh $@
+
+override_dh_auto_clean:
+ rm -f mozconfig
+ dh_auto_clean
+ find . -name '*.pyc' -delete
+
+override_dh_auto_configure:
+ cp ${MCFILE} mozconfig
+
+override_dh_auto_build:
+ make -f client.mk build
+
+override_dh_auto_install:
+ make -f client.mk DESTDIR=$$(pwd)/debian/newmoon prefix=/usr \
+ installdir=/usr/lib/newmoon \
+ sdkdir=/usr/lib/newmoon-devel install
+ rm -rf $$(pwd)/debian/newmoon/usr/share/idl
+ rm -rf $$(pwd)/debian/newmoon/usr/lib/newmoon-devel
+ rm -rf $$(pwd)/debian/newmoon/usr/include
+# remove vestigial duplicate file
+ rm -rf $$(pwd)/debian/newmoon/usr/lib/newmoon/palemoon-bin
+ mv $$(pwd)/debian/newmoon/usr/lib/newmoon/palemoon $$(pwd)/debian/newmoon/usr/lib/newmoon/newmoon
+
+override_dh_shlibdeps:
+ dh_shlibdeps -l /usr/lib/newmoon
+
+override_dh_strip_nondeterminism:
+ dh_strip_nondeterminism -Xdebian/newmoon/usr/lib/newmoon/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
bgstack15