summaryrefslogtreecommitdiff
path: root/newmoon/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'newmoon/debian/rules')
-rwxr-xr-xnewmoon/debian/rules21
1 files changed, 20 insertions, 1 deletions
diff --git a/newmoon/debian/rules b/newmoon/debian/rules
index bc24b7b..3d4ed6f 100755
--- a/newmoon/debian/rules
+++ b/newmoon/debian/rules
@@ -1,31 +1,49 @@
#!/usr/bin/make -f
+# Some Debian build tools clear out some variables
export SHELL=/bin/bash
+# stackrpms,2 just do not need lsb_release
+#distrel := $(shell lsb_release --codename --short)
+
+# Reduce memory usage of the linker at the expense of processing time
+# This should help on lower-end architectures like arm and mips, which
+# spend an immense amount of time swapping.
+LDFLAGS += -Wl,--reduce-memory-overheads
+LDFLAGS += -Wl,--no-keep-memory
+
+# Add execution time and memory usage stats in the logs
+LDFLAGS += -Wl,--stats
+
ifneq (,$(filter $(DEB_HOST_ARCH), armhf))
export DEB_CFLAGS_MAINT_APPEND = -mfpu=neon -funsafe-math-optimizations
export DEB_CXXFLAGS_MAINT_APPEND = -mfpu=neon -funsafe-math-optimizations
endif
%:
- dh $@ --without autoreconf
+ dh $@
override_dh_auto_clean:
dh_auto_clean
find . -name '*.pyc' -delete
rm -f mozconfig
+ #stackrpms,5
test -d palemoon/branding/unofficial.unbuilt && { \
rm -rf palemoon/branding/unofficial palemoon/branding/*.blue* ; \
mv palemoon/branding/unofficial.unbuilt palemoon/branding/unofficial ; \
} || :
+override_dh_autoreconf:
+
override_dh_auto_configure:
cp debian/mozconfig mozconfig
+ #stackrpms,4
! test -d palemoon/branding/unofficial.unbuilt && { \
cp -pr palemoon/branding/unofficial palemoon/branding/unofficial.unbuilt && \
tar -C palemoon/branding -zxf debian/bluemoon-icons.tgz ; } || :
override_dh_auto_build:
+ # building the stuff
make -f client.mk build
override_dh_auto_install:
@@ -37,6 +55,7 @@ override_dh_auto_install:
rm -rf $$(pwd)/debian/newmoon/usr/include
# remove vestigial duplicate file
rm -rf $$(pwd)/debian/newmoon/usr/lib/newmoon/palemoon-bin
+ #stackrpms,2
mv $$(pwd)/debian/newmoon/usr/lib/newmoon/palemoon $$(pwd)/debian/newmoon/usr/lib/newmoon/newmoon
rm -rf $$(pwd)/debian/newmoon/usr/bin/palemoon
bgstack15