summaryrefslogtreecommitdiff
path: root/move-to-next-monitor/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'move-to-next-monitor/debian/rules')
-rwxr-xr-xmove-to-next-monitor/debian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/move-to-next-monitor/debian/rules b/move-to-next-monitor/debian/rules
new file mode 100755
index 0000000..d127e1e
--- /dev/null
+++ b/move-to-next-monitor/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export name=move-to-next-monitor
+export version=0.0.1
+
+export use_git=1
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ # technically redundant as there is no compilation
+ make -f debian/move-to-next-monitor.Makefile
+
+override_dh_auto_install:
+ make -f debian/move-to-next-monitor.Makefile install -- DESTDIR=debian/${name}
bgstack15