summaryrefslogtreecommitdiff
path: root/mime_types_editor/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'mime_types_editor/debian/rules')
-rwxr-xr-xmime_types_editor/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/mime_types_editor/debian/rules b/mime_types_editor/debian/rules
new file mode 100755
index 0000000..069a230
--- /dev/null
+++ b/mime_types_editor/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+#override_dh_auto_install:
+# dh_auto_install -- prefix=/usr
+
+override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo
+ go-md2man < debian/mime_types_editor.1.md > debian/mime_types_editor.1
+ dh_install
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f debian/mime_types_editor.1 || :
bgstack15