summaryrefslogtreecommitdiff
path: root/mediaelch/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'mediaelch/debian/rules')
-rwxr-xr-xmediaelch/debian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/mediaelch/debian/rules b/mediaelch/debian/rules
new file mode 100755
index 0000000..6dc3662
--- /dev/null
+++ b/mediaelch/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+export QT_SELECT = 6
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -DUSE_EXTERN_QUAZIP:BOOL=ON
bgstack15