summaryrefslogtreecommitdiff
path: root/logout-manager/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'logout-manager/debian/rules')
-rwxr-xr-xlogout-manager/debian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/logout-manager/debian/rules b/logout-manager/debian/rules
new file mode 100755
index 0000000..c8755d8
--- /dev/null
+++ b/logout-manager/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+export APPNAME=logout-manager
+
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_auto_build:
+ dh_auto_build
+ sh debian/make-dsc-for-obs.sh
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr DEFAULTDIR='$$(DESTDIR)/etc/default'
+
+override_dh_gencontrol:
+ printf "misc:Depends=" > debian/${APPNAME}.substvars
+ make -C src deplist DISTRO=devuan SEPARATOR=',' | grep -vE 'make\[[0-9]' >> debian/${APPNAME}.substvars
+ dh_gencontrol
bgstack15