summaryrefslogtreecommitdiff
path: root/librewolf/debian/patches/librewolf
diff options
context:
space:
mode:
Diffstat (limited to 'librewolf/debian/patches/librewolf')
-rw-r--r--librewolf/debian/patches/librewolf/faster-package-multi-locale.patch88
-rw-r--r--librewolf/debian/patches/librewolf/librewolf-pref-pane.patch51
-rw-r--r--librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch4
-rw-r--r--librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.orig13
-rw-r--r--librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.rej16
-rw-r--r--librewolf/debian/patches/librewolf/remove_addons.patch25
-rw-r--r--librewolf/debian/patches/librewolf/remove_addons.patch.orig0
-rw-r--r--librewolf/debian/patches/librewolf/remove_addons.patch.rej12
-rw-r--r--librewolf/debian/patches/librewolf/webrender_ffi.patch15
9 files changed, 190 insertions, 34 deletions
diff --git a/librewolf/debian/patches/librewolf/faster-package-multi-locale.patch b/librewolf/debian/patches/librewolf/faster-package-multi-locale.patch
new file mode 100644
index 0000000..e61151a
--- /dev/null
+++ b/librewolf/debian/patches/librewolf/faster-package-multi-locale.patch
@@ -0,0 +1,88 @@
+diff --git a/python/mozbuild/mozbuild/mach_commands.py b/python/mozbuild/mozbuild/mach_commands.py
+--- a/python/mozbuild/mozbuild/mach_commands.py
++++ b/python/mozbuild/mozbuild/mach_commands.py
+@@ -2468,11 +2468,11 @@
+ @CommandArgument(
+ "--locales",
+ metavar="LOCALES",
+ nargs="+",
+ required=True,
+- help='List of locales to package, including "en-US"',
++ help="List of locales to package",
+ )
+ @CommandArgument(
+ "--verbose", action="store_true", help="Log informative status messages."
+ )
+ def package_l10n(command_context, verbose=False, locales=[]):
+@@ -2484,55 +2484,33 @@
+ "export BUILD_BACKENDS=FasterMake,RecursiveMake\n"
+ "in your mozconfig."
+ )
+ return 1
+
+- if "en-US" not in locales:
+- command_context.log(
+- logging.WARN,
+- "package-multi-locale",
+- {"locales": locales},
+- 'List of locales does not include default locale "en-US": '
+- '{locales}; adding "en-US"',
+- )
+- locales.append("en-US")
+- locales = list(sorted(locales))
++ locales = sorted(locale for locale in locales if locale != "en-US")
+
+ append_env = {
+ # We are only (re-)packaging, we don't want to (re-)build
+ # anything inside Gradle.
+ "GRADLE_INVOKED_WITHIN_MACH_BUILD": "1",
+ "MOZ_CHROME_MULTILOCALE": " ".join(locales),
+ }
+
+- for locale in locales:
+- if locale == "en-US":
+- command_context.log(
+- logging.INFO,
+- "package-multi-locale",
+- {"locale": locale},
+- "Skipping default locale {locale}",
+- )
+- continue
+-
+- command_context.log(
+- logging.INFO,
+- "package-multi-locale",
+- {"locale": locale},
+- "Processing chrome Gecko resources for locale {locale}",
+- )
+- command_context.run_process(
+- [
+- mozpath.join(command_context.topsrcdir, "mach"),
+- "build",
+- "chrome-{}".format(locale),
+- ],
+- append_env=append_env,
+- pass_thru=True,
+- ensure_exit_code=True,
+- cwd=mozpath.join(command_context.topsrcdir),
+- )
++ command_context.log(
++ logging.INFO,
++ "package-multi-locale",
++ {"locales": locales},
++ "Processing chrome Gecko resources for locales {locales}",
++ )
++ command_context._run_make(
++ directory=command_context.topobjdir,
++ target=["chrome-{}".format(locale) for locale in locales],
++ append_env=append_env,
++ pass_thru=False,
++ print_directory=False,
++ ensure_exit_code=True,
++ )
+
+ if command_context.substs["MOZ_BUILD_APP"] == "mobile/android":
+ command_context.log(
+ logging.INFO,
+ "package-multi-locale",
+
diff --git a/librewolf/debian/patches/librewolf/librewolf-pref-pane.patch b/librewolf/debian/patches/librewolf/librewolf-pref-pane.patch
index 9dcb97d..338415c 100644
--- a/librewolf/debian/patches/librewolf/librewolf-pref-pane.patch
+++ b/librewolf/debian/patches/librewolf/librewolf-pref-pane.patch
@@ -1,3 +1,28 @@
+From babb9dc13626b8d7096b3e9debd36a2404c34a80 Mon Sep 17 00:00:00 2001
+From: ohfp <1813007-ohfp@users.noreply.gitlab.com>
+Date: Tue, 12 Apr 2022 11:57:53 +0200
+Subject: [PATCH] port pref-pane patch changes to gecko-dev
+
+fix xorigin pref init and handling
+
+[LW] Ask to Restart Browser if Sync Pref in LW Settings is changed
+---
+ browser/components/preferences/jar.mn | 1 +
+ .../preferences/librewolf.inc.xhtml | 254 ++++++++++++++++
+ browser/components/preferences/librewolf.js | 287 ++++++++++++++++++
+ browser/components/preferences/preferences.js | 2 +
+ .../components/preferences/preferences.xhtml | 13 +
+ .../en-US/browser/preferences/preferences.ftl | 95 ++++++
+ browser/themes/shared/jar.inc.mn | 2 +
+ .../shared/preferences/category-librewolf.svg | 96 ++++++
+ .../themes/shared/preferences/librewolf.css | 23 ++
+ .../themes/shared/preferences/preferences.css | 4 +
+ 10 files changed, 777 insertions(+)
+ create mode 100644 browser/components/preferences/librewolf.inc.xhtml
+ create mode 100644 browser/components/preferences/librewolf.js
+ create mode 100644 browser/themes/shared/preferences/category-librewolf.svg
+ create mode 100644 browser/themes/shared/preferences/librewolf.css
+
diff --git a/browser/components/preferences/jar.mn b/browser/components/preferences/jar.mn
index 912d9edf0855..30a83da4edca 100644
--- a/browser/components/preferences/jar.mn
@@ -564,7 +589,7 @@ index 000000000000..c8cbb075d59b
+ });
+});
diff --git a/browser/components/preferences/preferences.js b/browser/components/preferences/preferences.js
-index f6dc2b3781f8..7d401fc63219 100644
+index 0a2a7895ae44..430f70cf06a2 100644
--- a/browser/components/preferences/preferences.js
+++ b/browser/components/preferences/preferences.js
@@ -8,6 +8,7 @@
@@ -622,13 +647,18 @@ index 81059f3d2e01..d815682d68bc 100644
#include sync.inc.xhtml
#include experimental.inc.xhtml
diff --git a/browser/locales/en-US/browser/preferences/preferences.ftl b/browser/locales/en-US/browser/preferences/preferences.ftl
-index f4d5eaea2193..46de6b40af65 100644
+index b10403800c7a..7f9bc2760342 100644
--- a/browser/locales/en-US/browser/preferences/preferences.ftl
+++ b/browser/locales/en-US/browser/preferences/preferences.ftl
-@@ -1409,3 +1409,93 @@ choose-download-folder-title = Choose Download Folder:
- # $service-name (String) - Name of a cloud storage provider like Dropbox, Google Drive, etc...
- save-files-to-cloud-storage =
- .label = Save files to { $service-name }
+@@ -1413,3 +1413,98 @@ httpsonly-radio-disabled =
+ desktop-folder-name = Desktop
+ downloads-folder-name = Downloads
+ choose-download-folder-title = Choose Download Folder:
++
++# Variables:
++# $service-name (String) - Name of a cloud storage provider like Dropbox, Google Drive, etc...
++save-files-to-cloud-storage =
++ .label = Save files to { $service-name }
+
+## LibreWolf preferences
+
@@ -720,7 +750,7 @@ index f4d5eaea2193..46de6b40af65 100644
+librewolf-config-link = All advanced settings (about:config)
+librewolf-open-profile = Open user profile directory
diff --git a/browser/themes/shared/jar.inc.mn b/browser/themes/shared/jar.inc.mn
-index 26f209ad7047..a305db88cbbd 100644
+index 615644e2f1de..df8e3a849a4c 100644
--- a/browser/themes/shared/jar.inc.mn
+++ b/browser/themes/shared/jar.inc.mn
@@ -106,6 +106,7 @@
@@ -736,9 +766,9 @@ index 26f209ad7047..a305db88cbbd 100644
skin/classic/browser/preferences/search.css (../shared/preferences/search.css)
skin/classic/browser/preferences/siteDataSettings.css (../shared/preferences/siteDataSettings.css)
+ skin/classic/browser/preferences/librewolf.css (../shared/preferences/librewolf.css)
- skin/classic/browser/upgradeDialog.css (../shared/upgradeDialog.css)
skin/classic/browser/spotlight.css (../shared/spotlight.css)
skin/classic/browser/upgradeDialog/abstract.png (../shared/upgradeDialog/abstract.png)
+ skin/classic/browser/upgradeDialog/cheers.png (../shared/upgradeDialog/cheers.png)
diff --git a/browser/themes/shared/preferences/category-librewolf.svg b/browser/themes/shared/preferences/category-librewolf.svg
new file mode 100644
index 000000000000..8ebf2ebe19a9
@@ -871,7 +901,7 @@ index 000000000000..12f926ab7018
+ fill: currentColor;
+}
diff --git a/browser/themes/shared/preferences/preferences.css b/browser/themes/shared/preferences/preferences.css
-index 406dc5603070..d6920777ec81 100644
+index 74493f3c59c4..2f3623cf6631 100644
--- a/browser/themes/shared/preferences/preferences.css
+++ b/browser/themes/shared/preferences/preferences.css
@@ -222,6 +222,10 @@ checkbox {
@@ -885,3 +915,6 @@ index 406dc5603070..d6920777ec81 100644
#category-sync > .category-icon {
list-style-image: url("chrome://browser/skin/preferences/category-sync.svg");
}
+--
+2.36.1
+
diff --git a/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch b/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch
index 1475de9..f82448f 100644
--- a/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch
+++ b/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch
@@ -1,6 +1,8 @@
+diff --git a/browser/components/preferences/preferences.js b/browser/components/preferences/preferences.js
+index 0a2a789..0601d28 100644
--- a/browser/components/preferences/preferences.js
+++ b/browser/components/preferences/preferences.js
-@@ -234,8 +234,6 @@
+@@ -234,8 +234,6 @@ function init_all() {
this.removeAttribute("keyboard-navigation");
});
diff --git a/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.orig b/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.orig
new file mode 100644
index 0000000..f82448f
--- /dev/null
+++ b/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.orig
@@ -0,0 +1,13 @@
+diff --git a/browser/components/preferences/preferences.js b/browser/components/preferences/preferences.js
+index 0a2a789..0601d28 100644
+--- a/browser/components/preferences/preferences.js
++++ b/browser/components/preferences/preferences.js
+@@ -234,8 +234,6 @@ function init_all() {
+ this.removeAttribute("keyboard-navigation");
+ });
+
+- maybeDisplayPoliciesNotice();
+-
+ window.addEventListener("hashchange", onHashChange);
+
+ document.getElementById("focusSearch1").addEventListener("command", () => {
diff --git a/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.rej b/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.rej
new file mode 100644
index 0000000..93fb568
--- /dev/null
+++ b/librewolf/debian/patches/librewolf/remove-organization-policy-banner.patch.rej
@@ -0,0 +1,16 @@
+--- patches/ui-patches/remove-organization-policy-banner.patch
++++ patches/ui-patches/remove-organization-policy-banner.patch
+@@ -1,6 +1,6 @@
+ --- a/browser/components/preferences/preferences.js
+ +++ b/browser/components/preferences/preferences.js
+-@@ -161,8 +161,6 @@
++@@ -234,8 +234,6 @@
+ this.removeAttribute("keyboard-navigation");
+ });
+
+@@ -8,4 +8,4 @@
+ -
+ window.addEventListener("hashchange", onHashChange);
+
+- gotoPref().then(() => {
++ document.getElementById("focusSearch1").addEventListener("command", () => {
diff --git a/librewolf/debian/patches/librewolf/remove_addons.patch b/librewolf/debian/patches/librewolf/remove_addons.patch
index 7a0e9e9..e818301 100644
--- a/librewolf/debian/patches/librewolf/remove_addons.patch
+++ b/librewolf/debian/patches/librewolf/remove_addons.patch
@@ -1,5 +1,5 @@
diff --git a/browser/extensions/moz.build b/browser/extensions/moz.build
-index 269dcb2..ed7c31d 100644
+index 0d4b9c3..d923333 100644
--- a/browser/extensions/moz.build
+++ b/browser/extensions/moz.build
@@ -5,11 +5,9 @@
@@ -15,10 +15,10 @@ index 269dcb2..ed7c31d 100644
"search-detection",
]
diff --git a/browser/locales/Makefile.in b/browser/locales/Makefile.in
-index 496379c..dd6f359 100644
+index e4b60a0..c38fdd2 100644
--- a/browser/locales/Makefile.in
+++ b/browser/locales/Makefile.in
-@@ -61,7 +61,6 @@ l10n-%:
+@@ -55,7 +55,6 @@ l10n-%:
ifneq (,$(wildcard ../extensions/formautofill/locales))
@$(MAKE) -C ../extensions/formautofill/locales AB_CD=$* XPI_NAME=locale-$*
endif
@@ -26,7 +26,7 @@ index 496379c..dd6f359 100644
@$(MAKE) -C ../../devtools/client/locales AB_CD=$* XPI_NAME=locale-$* XPI_ROOT_APPID='$(XPI_ROOT_APPID)'
@$(MAKE) -C ../../devtools/startup/locales AB_CD=$* XPI_NAME=locale-$* XPI_ROOT_APPID='$(XPI_ROOT_APPID)'
@$(MAKE) l10n AB_CD=$* XPI_NAME=locale-$* PREF_DIR=$(PREF_DIR)
-@@ -82,7 +81,6 @@ endif
+@@ -76,7 +75,6 @@ endif
@$(MAKE) -C ../../devtools/startup/locales chrome AB_CD=$*
@$(MAKE) chrome AB_CD=$*
@$(MAKE) -C $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales chrome AB_CD=$*
@@ -35,10 +35,10 @@ index 496379c..dd6f359 100644
package-win32-installer: $(SUBMAKEFILES)
$(MAKE) -C ../installer/windows CONFIG_DIR=l10ngen ZIP_IN='$(ZIP_OUT)' installer
diff --git a/browser/locales/filter.py b/browser/locales/filter.py
-index bb2e992..7d7768e 100644
+index 22eb5cb..5e1f09f 100644
--- a/browser/locales/filter.py
+++ b/browser/locales/filter.py
-@@ -19,7 +19,6 @@
+@@ -17,7 +17,6 @@ def test(mod, path, entity=None):
"devtools/startup",
"browser",
"browser/extensions/formautofill",
@@ -47,10 +47,10 @@ index bb2e992..7d7768e 100644
"other-licenses/branding/firefox",
"browser/branding/official",
diff --git a/browser/locales/l10n.ini b/browser/locales/l10n.ini
-index f4cb7ca..4efac13 100644
+index 7a65997..7f97667 100644
--- a/browser/locales/l10n.ini
+++ b/browser/locales/l10n.ini
-@@ -13,7 +13,6 @@
+@@ -13,7 +13,6 @@ dirs = browser
devtools/client
devtools/startup
browser/extensions/formautofill
@@ -59,16 +59,17 @@ index f4cb7ca..4efac13 100644
[includes]
# non-central apps might want to use %(topsrcdir)s here, or other vars
diff --git a/browser/locales/l10n.toml b/browser/locales/l10n.toml
-index b9b18fe..af7c583 100644
+index e9d5010..914a2f1 100644
--- a/browser/locales/l10n.toml
+++ b/browser/locales/l10n.toml
-@@ -132,10 +132,6 @@
+@@ -133,10 +133,6 @@ locales = [
+ reference = "browser/extensions/formautofill/locales/en-US/**"
l10n = "{l}browser/extensions/formautofill/**"
- [[paths]]
+-[[paths]]
- reference = "browser/extensions/report-site-issue/locales/en-US/**"
- l10n = "{l}browser/extensions/report-site-issue/**"
-
--[[paths]]
+ [[paths]]
reference = "services/sync/locales/en-US/**"
l10n = "{l}services/sync/**"
diff --git a/librewolf/debian/patches/librewolf/remove_addons.patch.orig b/librewolf/debian/patches/librewolf/remove_addons.patch.orig
deleted file mode 100644
index e69de29..0000000
--- a/librewolf/debian/patches/librewolf/remove_addons.patch.orig
+++ /dev/null
diff --git a/librewolf/debian/patches/librewolf/remove_addons.patch.rej b/librewolf/debian/patches/librewolf/remove_addons.patch.rej
deleted file mode 100644
index f8f82a8..0000000
--- a/librewolf/debian/patches/librewolf/remove_addons.patch.rej
+++ /dev/null
@@ -1,12 +0,0 @@
---- patches/remove_addons.patch
-+++ patches/remove_addons.patch
-@@ -12,8 +12,8 @@
- "webcompat",
- - "report-site-issue",
- "pictureinpicture",
-- "proxy-failover",
- "search-detection",
-+ ]
- diff --git a/browser/locales/Makefile.in b/browser/locales/Makefile.in
- index 496379c..dd6f359 100644
- --- a/browser/locales/Makefile.in
diff --git a/librewolf/debian/patches/librewolf/webrender_ffi.patch b/librewolf/debian/patches/librewolf/webrender_ffi.patch
new file mode 100644
index 0000000..21b1886
--- /dev/null
+++ b/librewolf/debian/patches/librewolf/webrender_ffi.patch
@@ -0,0 +1,15 @@
+Description: Remove an extra constant definition that is now being generated by newer versions of cbindgen (0.24), and causing build failures because it is defined in several places.
+Author: Olivier Tilloy <olivier.tilloy@canonical.com>
+Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1773259
+Forwarded: not-needed
+
+--- a/gfx/webrender_bindings/webrender_ffi.h
++++ b/gfx/webrender_bindings/webrender_ffi.h
+@@ -73,8 +73,6 @@ struct WrPipelineInfo;
+ struct WrPipelineIdAndEpoch;
+ using WrPipelineIdEpochs = nsTArray<WrPipelineIdAndEpoch>;
+
+-const uint64_t ROOT_CLIP_CHAIN = ~0;
+-
+ } // namespace wr
+ } // namespace mozilla
bgstack15