summaryrefslogtreecommitdiff
path: root/librewolf/debian/patches/debian-hacks
diff options
context:
space:
mode:
Diffstat (limited to 'librewolf/debian/patches/debian-hacks')
-rw-r--r--librewolf/debian/patches/debian-hacks/Add-another-preferences-directory-for-applications-p.patch6
-rw-r--r--librewolf/debian/patches/debian-hacks/Avoid-wrong-sessionstore-data-to-keep-windows-out-of.patch16
-rw-r--r--librewolf/debian/patches/debian-hacks/Relax-MSRV-to-1.56.0.patch32
-rw-r--r--librewolf/debian/patches/debian-hacks/Use-the-Mozilla-Location-Service-key-when-the-Google.patch4
4 files changed, 29 insertions, 29 deletions
diff --git a/librewolf/debian/patches/debian-hacks/Add-another-preferences-directory-for-applications-p.patch b/librewolf/debian/patches/debian-hacks/Add-another-preferences-directory-for-applications-p.patch
index 07e1119..7206ab5 100644
--- a/librewolf/debian/patches/debian-hacks/Add-another-preferences-directory-for-applications-p.patch
+++ b/librewolf/debian/patches/debian-hacks/Add-another-preferences-directory-for-applications-p.patch
@@ -13,10 +13,10 @@ to disable the "set as default browser" dialog.
1 file changed, 2 insertions(+)
diff --git a/toolkit/xre/nsXREDirProvider.cpp b/toolkit/xre/nsXREDirProvider.cpp
-index a9d291b..c4a37fe 100644
+index f0e449c..89b07ad 100644
--- a/toolkit/xre/nsXREDirProvider.cpp
+++ b/toolkit/xre/nsXREDirProvider.cpp
-@@ -802,6 +802,7 @@ static const char* const kAppendPrefDir[] = {"defaults", "preferences",
+@@ -768,6 +768,7 @@ static const char* const kAppendPrefDir[] = {"defaults", "preferences",
static const char* const kAppendBackgroundTasksPrefDir[] = {
"defaults", "backgroundtasks", nullptr};
#endif
@@ -24,7 +24,7 @@ index a9d291b..c4a37fe 100644
nsresult nsXREDirProvider::GetFilesInternal(const char* aProperty,
nsISimpleEnumerator** aResult) {
-@@ -818,6 +819,7 @@ nsresult nsXREDirProvider::GetFilesInternal(const char* aProperty,
+@@ -784,6 +785,7 @@ nsresult nsXREDirProvider::GetFilesInternal(const char* aProperty,
LoadDirIntoArray(mXULAppDir, kAppendBackgroundTasksPrefDir, directories);
}
#endif
diff --git a/librewolf/debian/patches/debian-hacks/Avoid-wrong-sessionstore-data-to-keep-windows-out-of.patch b/librewolf/debian/patches/debian-hacks/Avoid-wrong-sessionstore-data-to-keep-windows-out-of.patch
index 094cb02..11b65a0 100644
--- a/librewolf/debian/patches/debian-hacks/Avoid-wrong-sessionstore-data-to-keep-windows-out-of.patch
+++ b/librewolf/debian/patches/debian-hacks/Avoid-wrong-sessionstore-data-to-keep-windows-out-of.patch
@@ -12,19 +12,19 @@ Closes: #552426, #553453
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/browser/components/sessionstore/SessionStore.jsm b/browser/components/sessionstore/SessionStore.jsm
-index 79366e4..0891d87 100644
+index 650a597..de13b8a 100644
--- a/browser/components/sessionstore/SessionStore.jsm
+++ b/browser/components/sessionstore/SessionStore.jsm
-@@ -4923,7 +4923,7 @@ var SessionStoreInternal = {
- !isNaN(aTop) &&
- (aLeft != win_("screenX") || aTop != win_("screenY"))
- ) {
-- aWindow.moveTo(aLeft, aTop);
-+ aWindow.moveTo((aLeft < -aWidth) ? 0 : aLeft, (aTop < -aHeight) ? 0 : aTop);
+@@ -5012,7 +5012,7 @@ var SessionStoreInternal = {
+ // _getWindowDimension.
+ let desktopToCssScale =
+ aWindow.desktopToDeviceScale / aWindow.devicePixelRatio;
+- aWindow.moveTo(aLeft * desktopToCssScale, aTop * desktopToCssScale);
++ aWindow.moveTo((aLeft < -aWidth) ? 0 : aLeft * desktopToCssScale, (aTop < -aHeight) ? 0 : aTop * desktopToCssScale);
}
if (
aWidth &&
-@@ -4952,9 +4952,8 @@ var SessionStoreInternal = {
+@@ -5041,9 +5041,8 @@ var SessionStoreInternal = {
case "minimized":
if (aSizeModeBeforeMinimized == "maximized") {
aWindow.maximize();
diff --git a/librewolf/debian/patches/debian-hacks/Relax-MSRV-to-1.56.0.patch b/librewolf/debian/patches/debian-hacks/Relax-MSRV-to-1.56.0.patch
index d8d60c4..46b1035 100644
--- a/librewolf/debian/patches/debian-hacks/Relax-MSRV-to-1.56.0.patch
+++ b/librewolf/debian/patches/debian-hacks/Relax-MSRV-to-1.56.0.patch
@@ -21,7 +21,7 @@ Subject: Relax MSRV to 1.56.0
create mode 100644 third_party/rust/audioipc2-client/build.rs
diff --git a/Cargo.lock b/Cargo.lock
-index c90fafe..91370ed 100644
+index 391b904..77c1d86 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -297,6 +297,7 @@ dependencies = [
@@ -32,7 +32,7 @@ index c90fafe..91370ed 100644
]
[[package]]
-@@ -4874,6 +4875,7 @@ dependencies = [
+@@ -4925,6 +4926,7 @@ dependencies = [
"precomputed-hash",
"rayon",
"regex",
@@ -54,12 +54,12 @@ index ce3652d..c8a966b 100644
RUSTC_BOOTSTRAP := $(RUSTC_BOOTSTRAP),encoding_rs,packed_simd
endif
diff --git a/python/mozboot/mozboot/util.py b/python/mozboot/mozboot/util.py
-index 484ff52..b3990f6 100644
+index 1d6d546..fdbf48f 100644
--- a/python/mozboot/mozboot/util.py
+++ b/python/mozboot/mozboot/util.py
-@@ -12,7 +12,7 @@ from mach.site import PythonVirtualenv
- from mach.util import get_state_dir
-
+@@ -23,7 +23,7 @@ if sys.version_info < (3,):
+ else:
+ from urllib.request import urlopen
-MINIMUM_RUST_VERSION = "1.57.0"
+MINIMUM_RUST_VERSION = "1.56.0"
@@ -121,10 +121,10 @@ index ee156cf..7048ea0 100644
}
diff --git a/servo/components/style/stylist.rs b/servo/components/style/stylist.rs
-index 9d5e38d..c72d46f 100644
+index 02610fe..63e2209 100644
--- a/servo/components/style/stylist.rs
+++ b/servo/components/style/stylist.rs
-@@ -1747,7 +1747,7 @@ impl ExtraStyleData {
+@@ -1730,7 +1730,7 @@ impl ExtraStyleData {
// TODO: Handle pseudo-classes
self.pages.named.try_reserve(page_rule.selectors.0.len())?;
for name in page_rule.selectors.as_slice() {
@@ -134,21 +134,21 @@ index 9d5e38d..c72d46f 100644
vec.push(PageRuleData{layer, rule: rule.clone()});
}
diff --git a/third_party/rust/audioipc2-client/.cargo-checksum.json b/third_party/rust/audioipc2-client/.cargo-checksum.json
-index 85789ad..3365cd7 100644
+index 6c0cbc0..f033549 100644
--- a/third_party/rust/audioipc2-client/.cargo-checksum.json
+++ b/third_party/rust/audioipc2-client/.cargo-checksum.json
@@ -1 +1 @@
--{"files":{"Cargo.toml":"4304d6695b5ae83a67ec50eeb7c8b05f0292b31bf6d93bfec629492116cb05fd","cbindgen.toml":"fb6abe1671497f432a06e40b1db7ed7cd2cceecbd9a2382193ad7534e8855e34","src/context.rs":"060680f87d406cef1f6f94cfae991ae59b5f3a13253e15481716a1a4224682ee","src/lib.rs":"c4a6797734489280f6b97dd72c9e51a7bd7be4104592eece3929e29d45cbca4a","src/send_recv.rs":"450bdb1d8a346634c0237f2081b424d11e2c19ad81670009303f8a03b3bfb196","src/stream.rs":"8f2f33b75b78fb1ef8ebb7b14bbb81dbb0f046f9e91b6110a3c49e424690bb8b"},"package":null}
+-{"files":{"Cargo.toml":"722e0313d4de90477ae34dbb95ae7eeff27622329c5689bb4ce6bcd2006c6263","cbindgen.toml":"fb6abe1671497f432a06e40b1db7ed7cd2cceecbd9a2382193ad7534e8855e34","src/context.rs":"33231853817615e01fd1a0f67f69a176d19119bbebb7dc417e96ed88dd3a8d34","src/lib.rs":"c4a6797734489280f6b97dd72c9e51a7bd7be4104592eece3929e29d45cbca4a","src/send_recv.rs":"064a657c845762be1dbcbbfc18b3f8a51582eb540def8d2ceecf200184ad4f7a","src/stream.rs":"a6c07796e6fe704cfa6baf8b904e7ffe874d3c884d44d4ed307e668dec25452b"},"package":null}
\ No newline at end of file
-+{"files":{"Cargo.toml":"fcf7b1d8c3f72ecac29ebe859e7ea5e216168aad149fad0284a81015bd88c329","build.rs":"91de386f621a91eb125484980f352d52549826c27d1ddff53ce6e3835c79e61d","cbindgen.toml":"fb6abe1671497f432a06e40b1db7ed7cd2cceecbd9a2382193ad7534e8855e34","src/context.rs":"060680f87d406cef1f6f94cfae991ae59b5f3a13253e15481716a1a4224682ee","src/lib.rs":"78c7060e55536cbff4681a300e73c7fa0ff52953caa668c84035d2e975b6871d","src/send_recv.rs":"450bdb1d8a346634c0237f2081b424d11e2c19ad81670009303f8a03b3bfb196","src/stream.rs":"8f2f33b75b78fb1ef8ebb7b14bbb81dbb0f046f9e91b6110a3c49e424690bb8b"},"package":null}
++{"files":{"Cargo.toml":"bdde450635daff287c6a94115c801ccc274766f455dd1606dbdf595158668d4f","build.rs":"91de386f621a91eb125484980f352d52549826c27d1ddff53ce6e3835c79e61d","cbindgen.toml":"fb6abe1671497f432a06e40b1db7ed7cd2cceecbd9a2382193ad7534e8855e34","src/context.rs":"33231853817615e01fd1a0f67f69a176d19119bbebb7dc417e96ed88dd3a8d34","src/lib.rs":"78c7060e55536cbff4681a300e73c7fa0ff52953caa668c84035d2e975b6871d","src/send_recv.rs":"064a657c845762be1dbcbbfc18b3f8a51582eb540def8d2ceecf200184ad4f7a","src/stream.rs":"a6c07796e6fe704cfa6baf8b904e7ffe874d3c884d44d4ed307e668dec25452b"},"package":null}
diff --git a/third_party/rust/audioipc2-client/Cargo.toml b/third_party/rust/audioipc2-client/Cargo.toml
-index 94afedb..b0a63ea 100644
+index fe71197..ddab501 100644
--- a/third_party/rust/audioipc2-client/Cargo.toml
+++ b/third_party/rust/audioipc2-client/Cargo.toml
-@@ -14,3 +14,6 @@ audio_thread_priority = "0.23.4"
- audioipc = { package = "audioipc2", path="../audioipc" }
- cubeb-backend = "0.9"
- log = "0.4"
+@@ -18,3 +18,6 @@ log = "0.4"
+ version = "0.26.0"
+ default_features = false
+ features = ["winapi"]
+
+[build-dependencies]
+rustc_version = "0.2"
diff --git a/librewolf/debian/patches/debian-hacks/Use-the-Mozilla-Location-Service-key-when-the-Google.patch b/librewolf/debian/patches/debian-hacks/Use-the-Mozilla-Location-Service-key-when-the-Google.patch
index 1732338..62ee664 100644
--- a/librewolf/debian/patches/debian-hacks/Use-the-Mozilla-Location-Service-key-when-the-Google.patch
+++ b/librewolf/debian/patches/debian-hacks/Use-the-Mozilla-Location-Service-key-when-the-Google.patch
@@ -7,10 +7,10 @@ Subject: Use the Mozilla Location Service key when the Google Key is not there
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/modules/libpref/init/all.js b/modules/libpref/init/all.js
-index 37dd370..de83075 100644
+index 261e46f..6443cf1 100644
--- a/modules/libpref/init/all.js
+++ b/modules/libpref/init/all.js
-@@ -3725,7 +3725,7 @@ pref("network.psl.onUpdate_notify", false);
+@@ -3701,7 +3701,7 @@ pref("network.psl.onUpdate_notify", false);
// All the Geolocation preferences are here.
//
bgstack15