summaryrefslogtreecommitdiff
path: root/libreoffice-tango-iconset/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'libreoffice-tango-iconset/debian/rules')
-rwxr-xr-xlibreoffice-tango-iconset/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/libreoffice-tango-iconset/debian/rules b/libreoffice-tango-iconset/debian/rules
new file mode 100755
index 0000000..d8261ca
--- /dev/null
+++ b/libreoffice-tango-iconset/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install
+ 7za -aoa x tango-iconset.oxt
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf $$( 7za l tango-iconset.oxt | awk 'NF==6 && $$1 ~/[0-9]{4}(-[0-9]{2}){2}/{print $$NF}' )
bgstack15