summaryrefslogtreecommitdiff
path: root/freefilesync/freefilesync.spec
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/freefilesync.spec')
-rw-r--r--freefilesync/freefilesync.spec28
1 files changed, 20 insertions, 8 deletions
diff --git a/freefilesync/freefilesync.spec b/freefilesync/freefilesync.spec
index 7c45e91..fb7c4a3 100644
--- a/freefilesync/freefilesync.spec
+++ b/freefilesync/freefilesync.spec
@@ -14,7 +14,7 @@
%define min_openssl >= 1.1.0h
%endif
Name: freefilesync
-Version: 10.11
+Version: 10.12
Release: 1%{?dist}
Summary: A file synchronization utility
@@ -26,6 +26,7 @@ URL: http://www.freefilesync.org/
Source0: https://gitlab.com/opensource-tracking/%{pkgname}/-/archive/%{version}/%{pkgname}-%{version}.tar.gz
Source1: %{pkgname}.desktop
Source2: %{prog2name}.desktop
+Source3: %{name}.xml
Patch0: ffs_allow_parallel_ops.patch
Patch1: ffs_no_check_updates.patch
Patch2: ffs_no_wx311.patch
@@ -59,6 +60,9 @@ BuildRequires: openssl-devel
%endif
Requires: hicolor-icon-theme
Requires: xdg-utils
+Provides: mimehandler(application/x-freefilesync-ffs)
+Provides: mimehandler(application/x-freefilesync-real)
+Provides: mimehandler(application/x-freefilesync-batch)
%description
FreeFileSync is a free Open Source software that helps you synchronize
@@ -113,8 +117,7 @@ EOF
pushd %{pkgname}/Build
install -d %{buildroot}%{_bindir} %{buildroot}%{_datadir}/%{name}
install -Dm 0755 -t %{buildroot}%{_bindir} Bin/%{pkgname} Bin/%{prog2name}
-cp -pr Languages %{buildroot}%{_datadir}/%{name}
-install -Dm 0644 ding.wav gong.wav harp.wav Resources.zip styles.gtk_rc %{buildroot}%{_datadir}/%{name}
+cp -pr Languages Misc %{buildroot}%{_datadir}/%{name}
popd
%endif
@@ -133,18 +136,20 @@ desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE2}
# none
# mimetypes
-# none
+install -d %{buildroot}%{_datadir}/mime/packages
+install -Dm 0644 -t %{buildroot}%{_datadir}/mime/packages %{SOURCE3}
# icons
-unzip %{pkgname}/Build/Resources.zip %{pkgname}.png %{prog2name}.png
+unzip %{pkgname}/Build/Misc/Icons.zip file_batch.png
for res in 16 22 24 32 48 64 96 128 256 ;do
dir=%{buildroot}%{_datadir}/icons/hicolor/${res}x${res}/apps
- mkdir -p ${dir}
+ mkdir -p ${dir} ${dir}/../mimetypes
for icon in %{pkgname} %{prog2name} ;do
- convert ${icon}.png -filter Lanczos -resize ${res}x${res} \
+ convert %{pkgname}/Build/Misc/${icon}.png -filter Lanczos -resize ${res}x${res} \
${dir}/${icon}.png
done
+ convert file_batch.png -filter Lanczos -resize ${res}x${res} ${dir}/../mimetypes/application-x-freefilesync-batch.png
done
%clean
@@ -170,6 +175,7 @@ fi
%posttrans
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
+update-mime-database -n ${_datadir}/mime 1>/dev/null 2>&1 || :
%files
%license %attr(444, -, -) License.txt
@@ -177,11 +183,17 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_bindir}/%{pkgname}
%{_bindir}/%{prog2name}
%{_datadir}/applications/*.desktop
-%{_datadir}/icons/hicolor/*x*/apps/*.png
+%{_datadir}/icons/hicolor/*x*/*/*.png
+%{_datadir}/mime/packages/*
%{_datadir}/%{name}
%ghost %config %attr(666, -, -) %{_datadir}/%{name}/GlobalSettings.xml
%changelog
+* Sun May 12 2019 B Stack <bgstack15@gmail.com> - 10.12-1
+- version bump
+- improve icons used from upstream, to match dpkg
+- add mimetypes, to match dpkg
+
* Fri Apr 12 2019 B Stack <bgstack15@gmail.com> - 10.11-1
- version bump
bgstack15