summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/changelog34
-rw-r--r--freefilesync/debian/patches/ffs_devuan.patch64
-rw-r--r--freefilesync/debian/patches/ffs_libssh2.patch21
-rw-r--r--freefilesync/debian/patches/ffs_makefile.patch32
-rw-r--r--freefilesync/debian/patches/series2
5 files changed, 104 insertions, 49 deletions
diff --git a/freefilesync/debian/changelog b/freefilesync/debian/changelog
index 914b53d..c3ee4a9 100644
--- a/freefilesync/debian/changelog
+++ b/freefilesync/debian/changelog
@@ -1,3 +1,37 @@
+freefilesync (10.11-1+devuan) manual; urgency=low
+
+ * Last FreeFileSync version supporting Windows XP and Vista
+ * Fixed crash on multi-monitor set up
+ * Fixed dialogs not showing after opening UAC prompt
+ * Support launching through symlink (Linux)
+ * Added example desktop starter files (Linux)
+ * Fixed misleading error when determining file permissions support
+ * Updated wxWidgets, libcurl, libssh2, VS, GCC, Xcode
+
+ -- B Stack <bgstack15@gmail.com> Fri, 12 Apr 2019 13:30:42 -0500
+
+freefilesync (10.10-1devuan) manual; urgency=low
+
+ * New option: synchronize selection
+ * Dynamically disable unsuitable context menu options
+ * Support MTP devices without move command
+ * Fall back to copy/delete when implicitly moving to different device (e.g. symlink)
+ * Fixed incorrect statistics after parallel move
+ * Fixed menu button not triggering context menu
+ * Fixed crash on focus change while message popup is dismissed
+ * Fixed crash when trying to shrink empty image
+ * Fixed invisible dialogs when monitor is turned off in multi-monitor setup
+ * Work around GetFileInformationByHandle error code 58 on WD My Cloud EX
+ * Changing deletion handling now correctly triggers updated config
+ * Support root-relative FTP file paths (e.g. FreeNAS)
+ * Move and rename MTP items as a transaction
+ * Exclude AppleDouble files (._) via default filter on macOS
+ * Support home path for FTP folder picker
+ * Use server default permissions when creating SFTP folder
+ * Use native OpenSSL AES-CTR rather than libssh2 fallback
+ * Added context information for cloud connection errors
+ * Updated translation files
+
freefilesync (10.9-1devuan) manual; urgency=low
* Added FTP, SFTP, Google Drive support for Linux
diff --git a/freefilesync/debian/patches/ffs_devuan.patch b/freefilesync/debian/patches/ffs_devuan.patch
index ff840d7..977fa2b 100644
--- a/freefilesync/debian/patches/ffs_devuan.patch
+++ b/freefilesync/debian/patches/ffs_devuan.patch
@@ -1,19 +1,7 @@
-diff -Naur -x '*.orig' -x '*.rej' 10.3-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.3-2/FreeFileSync/Source/ui/small_dlgs.cpp
---- 10.3-0/FreeFileSync/Source/ui/small_dlgs.cpp 2018-08-07 05:03:34.000000000 -0400
-+++ 10.3-2/FreeFileSync/Source/ui/small_dlgs.cpp 2018-08-29 22:13:40.240595334 -0400
-@@ -106,6 +106,8 @@
- L" x64";
- #endif
-
-+ build +=
-+ L" for Devuan";
-
- GetSizer()->SetSizeHints(this); //~=Fit() + SetMinSize()
-
-diff -Naur 10.6-0/FreeFileSync/Source/base/ffs_paths.cpp 10.6-1/FreeFileSync/Source/base/ffs_paths.cpp
---- 10.6-0/FreeFileSync/Source/base/ffs_paths.cpp 2018-11-13 06:58:40.771249592 -0500
-+++ 10.6-1/FreeFileSync/Source/base/ffs_paths.cpp 2018-11-16 21:34:30.341077845 -0500
-@@ -66,7 +66,7 @@
+diff -Naur -x '*.orig' -x '*.rej' 10.11-0/FreeFileSync/Source/base/ffs_paths.cpp 10.11-1/FreeFileSync/Source/base/ffs_paths.cpp
+--- 10.11-0/FreeFileSync/Source/base/ffs_paths.cpp 2019-04-12 08:05:57.000000000 -0400
++++ 10.11-1/FreeFileSync/Source/base/ffs_paths.cpp 2019-04-12 13:58:55.050550183 -0400
+@@ -59,7 +59,7 @@
ZEN_ON_SCOPE_EXIT(wxTheApp->SetAppName(appName));
//if (isPortableVersion())
@@ -22,3 +10,47 @@ diff -Naur 10.6-0/FreeFileSync/Source/base/ffs_paths.cpp 10.6-1/FreeFileSync/Sou
//else //use OS' standard paths
// return appendSeparator(utfTo<Zstring>(wxStandardPathsBase::Get().GetResourcesDir()));
}
+diff -Naur -x '*.orig' -x '*.rej' 10.11-0/FreeFileSync/Source/Makefile 10.11-1/FreeFileSync/Source/Makefile
+--- 10.11-0/FreeFileSync/Source/Makefile 2019-04-12 08:05:57.000000000 -0400
++++ 10.11-1/FreeFileSync/Source/Makefile 2019-04-12 14:00:16.774552362 -0400
+@@ -1,10 +1,10 @@
+-EXENAME = FreeFileSync_$(shell arch)
++EXENAME = FreeFileSync
+
+ CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -DLIBSSH2_OPENSSL -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+ -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
+
+-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+
+
+ CXXFLAGS += `pkg-config --cflags openssl`
+diff -Naur -x '*.orig' -x '*.rej' 10.11-0/FreeFileSync/Source/RealTimeSync/Makefile 10.11-1/FreeFileSync/Source/RealTimeSync/Makefile
+--- 10.11-0/FreeFileSync/Source/RealTimeSync/Makefile 2019-04-12 08:05:57.000000000 -0400
++++ 10.11-1/FreeFileSync/Source/RealTimeSync/Makefile 2019-04-12 13:59:53.934551753 -0400
+@@ -1,10 +1,10 @@
+-EXENAME = RealTimeSync_$(shell arch)
++EXENAME = RealTimeSync
+
+ CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+ -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
+
+-LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+
+ #Gtk - support "no button border"
+ CXXFLAGS += `pkg-config --cflags gtk+-2.0`
+diff -Naur -x '*.orig' -x '*.rej' 10.11-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.11-1/FreeFileSync/Source/ui/small_dlgs.cpp
+--- 10.11-0/FreeFileSync/Source/ui/small_dlgs.cpp 2019-04-12 08:05:57.000000000 -0400
++++ 10.11-1/FreeFileSync/Source/ui/small_dlgs.cpp 2019-04-12 13:58:55.050550183 -0400
+@@ -115,6 +115,8 @@
+ L" x64";
+ #endif
+
++ build +=
++ L" for Devuan";
+
+ GetSizer()->SetSizeHints(this); //~=Fit() + SetMinSize()
+
diff --git a/freefilesync/debian/patches/ffs_libssh2.patch b/freefilesync/debian/patches/ffs_libssh2.patch
new file mode 100644
index 0000000..81287a3
--- /dev/null
+++ b/freefilesync/debian/patches/ffs_libssh2.patch
@@ -0,0 +1,21 @@
+Source: https://aur.archlinux.org/cgit/aur.git/commit/?h=freefilesync&id=7e1524db8e0243ff9d7b7dcba64a3a5228295725
+Author: Simon Brulhart
+Message: libssh2 v1.8.0 does not yet implement LIBSSH2_SFTP_DEFAULT_MODE, revert to previous impl.
+Method:
+
+ sed -e 's/LIBSSH2_SFTP_DEFAULT_MODE/LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO/g' -i 'FreeFileSync/Source/fs/sftp.cpp'
+
+diff -x '*.swp' -x .git -Naur 10.10-0/FreeFileSync/Source/fs/sftp.cpp 10.10-1/FreeFileSync/Source/fs/sftp.cpp
+--- 10.10-0/FreeFileSync/Source/fs/sftp.cpp 2019-03-12 08:09:58.465098982 -0400
++++ 10.10-1/FreeFileSync/Source/fs/sftp.cpp 2019-03-12 08:27:05.718963710 -0400
+@@ -1657,8 +1657,8 @@
+ runSftpCommand(login_, L"libssh2_sftp_mkdir", //throw SysError
+ [&](const SshSession::Details& sd) //noexcept!
+ {
+-#if 1 //let's see how LIBSSH2_SFTP_DEFAULT_MODE works out:
+- return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath).c_str(), LIBSSH2_SFTP_DEFAULT_MODE);
++#if 1 //let's see how LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO works out:
++ return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath).c_str(), LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO);
+ #else //default for newly created directories: 0777
+ return ::libssh2_sftp_mkdir(sd.sftpChannel, getLibssh2Path(afsPath).c_str(), LIBSSH2_SFTP_S_IRWXU | LIBSSH2_SFTP_S_IRWXG | LIBSSH2_SFTP_S_IRWXO);
+ #endif
diff --git a/freefilesync/debian/patches/ffs_makefile.patch b/freefilesync/debian/patches/ffs_makefile.patch
deleted file mode 100644
index 79a8233..0000000
--- a/freefilesync/debian/patches/ffs_makefile.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur -x '*.orig' -x '*.rej' 10.9-0/FreeFileSync/Source/Makefile 10.9-1/FreeFileSync/Source/Makefile
---- 10.3-0/FreeFileSync/Source/Makefile 2019-02-10 22:01:42.138160180 -0500
-+++ 10.9-1/FreeFileSync/Source/Makefile 2019-02-11 21:48:19.729739859 -0500
-@@ -1,10 +1,10 @@
--EXENAME = FreeFileSync_$(shell arch)
-+EXENAME = FreeFileSync
-
- CXXFLAGS = -std=c++17 -pipe -DWXINTL_NO_GETTEXT_MACRO -DLIBSSH2_OPENSSL -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
- -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
- -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
-
--LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
-
-
- CXXFLAGS += `pkg-config --cflags openssl`
-diff -Naur -x '*.orig' -x '*.rej' 10.9-0/FreeFileSync/Source/RealTimeSync/Makefile 10.9-1/FreeFileSync/Source/RealTimeSync/Makefile
---- 10.3-0/FreeFileSync/Source/RealTimeSync/Makefile 2019-02-10 22:01:42.141160214 -0500
-+++ 10.9-1/FreeFileSync/Source/RealTimeSync/Makefile 2019-02-11 21:48:22.504771344 -0500
-@@ -1,10 +1,10 @@
--EXENAME = RealTimeSync_$(shell arch)
-+EXENAME = RealTimeSync
-
- CXXFLAGS = -std=c++17 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
- -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
- -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
-
--LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
-
- #Gtk - support "no button border"
- CXXFLAGS += `pkg-config --cflags gtk+-2.0`
diff --git a/freefilesync/debian/patches/series b/freefilesync/debian/patches/series
index 2dbed63..bca1534 100644
--- a/freefilesync/debian/patches/series
+++ b/freefilesync/debian/patches/series
@@ -1,7 +1,7 @@
ffs_allow_parallel_ops.patch
ffs_devuan.patch
-ffs_makefile.patch
ffs_no_check_updates.patch
ffs_no_wx311.patch
ffs_old_libcurl.patch
ffs_sftp.patch
+ffs_libssh2.patch
bgstack15