summaryrefslogtreecommitdiff
path: root/freefilesync/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/rules')
-rwxr-xr-xfreefilesync/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/freefilesync/debian/rules b/freefilesync/debian/rules
index 6ebd427..a359bd9 100755
--- a/freefilesync/debian/rules
+++ b/freefilesync/debian/rules
@@ -4,6 +4,7 @@
#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export linkFlags="${LDFLAGS} -pie"
export appname=freefilesync
export pkgname=FreeFileSync
@@ -14,6 +15,8 @@ export buildroot="${debuilddir}/${appname}"
export _datadir="/usr/share"
export _bindir="/usr/bin"
+export TMPDIR=/tmp
+
%:
dh $@
@@ -93,3 +96,7 @@ override_dh_auto_install:
convert ${pkgname}/Build/Resources/${prog2name}.png -filter Lanczos -resize 128x128 ${buildroot}${_datadir}/icons/hicolor/128x128/mimetypes/application-x-freefilesync-real.png
rm -f file_batch.png file_sync.png
+
+override_dh_fixperms:
+ dh_fixperms || :
+ chmod 0644 ${buildroot}${_datadir}/${appname}/* || :
bgstack15