summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch')
-rw-r--r--freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch55
1 files changed, 18 insertions, 37 deletions
diff --git a/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch b/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
index 12a1b43..1a468db 100644
--- a/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
+++ b/freefilesync/debian/patches/revert_zenju_aggressive_upstreamisms.patch
@@ -92,35 +92,21 @@ diff -x '*.rej' -x '*.orig' -x '*.git*' -Naur 10.24-0/wx+/choice_enum.h 10.24-1/
}
}
-
-Version: 11.1
-Message: this one is really just a fix of Zenju's sloppy Makefile. He'll figure it out on his own for v11.2. If I tell him now, he'll replace the source tarball for 11.1 which will mess up everyone's checksums.
-diff -x '*.orig' -x '*.rej' -aur 11.1-1/FreeFileSync/Source/Makefile 11.1-2/FreeFileSync/Source/Makefile
---- 11.1-1/FreeFileSync/Source/Makefile 2020-09-01 20:07:26.751011466 -0400
-+++ 11.1-2/FreeFileSync/Source/Makefile 2020-09-01 20:17:31.030611773 -0400
-@@ -95,6 +95,7 @@
- cppFiles+=../../zen/shutdown.cpp
- cppFiles+=../../zen/sys_error.cpp
- cppFiles+=../../zen/sys_info.cpp
-+cppFiles+=../../zen/sys_version.cpp
- cppFiles+=../../zen/thread.cpp
- cppFiles+=../../zen/zlib_wrap.cpp
- cppFiles+=../../wx+/file_drop.cpp
Message: Now have to revert wxWidgets 3.1.4 upstreamisms
cd 11.1-0 ; git diff HEAD~1 -- $( grep -l -rIE 'wxASCII_STR' ) > ~/foo1 ; ( cd ../11.1-2 ; vi ~/foo1 $( grep -l -rIE 'wxASCII_STR' ) ; )
cd 11.1-0 ; git diff HEAD~1 -- $( grep -l -rIE 'wxDD_SHOW_HIDDEN' ) > ~/foo1 ; ( cd ../11.1-2 ; vi ~/foo1 $( grep -l -rIE 'wxDD_SHOW_HIDDEN' ) ; )
-diff -x '*.orig' -x '*.rej' -aur 11.1-1/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp 11.1-2/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp
---- 11.1-1/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp 2020-09-01 19:07:43.703122022 -0400
-+++ 11.1-2/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp 2020-09-01 20:13:16.679447647 -0400
-@@ -145,7 +145,7 @@
+diff -x '*.orig' -x '*.rej' -aur 11.2-0/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp 11.2-1/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp
+--- 11.2-0/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp 2020-10-02 14:39:05.273463072 -0400
++++ 11.2-1/FreeFileSync/Source/RealTimeSync/folder_selector2.cpp 2020-10-02 15:06:56.670070620 -0400
+@@ -158,7 +158,7 @@
}
Zstring newFolderPath;
-- wxDirDialog dirPicker(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderPath), wxDD_DEFAULT_STYLE | wxDD_SHOW_HIDDEN);
-+ wxDirDialog dirPicker(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderPath)); //put modal wxWidgets dialogs on stack: creating on freestore leads to memleak!
- if (dirPicker.ShowModal() != wxID_OK)
+- wxDirDialog folderSelector(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderPath), wxDD_DEFAULT_STYLE | wxDD_SHOW_HIDDEN);
++ wxDirDialog folderSelector(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderPath));
+ if (folderSelector.ShowModal() != wxID_OK)
return;
- newFolderPath = utfTo<Zstring>(dirPicker.GetPath());
+ newFolderPath = utfTo<Zstring>(folderSelector.GetPath());
diff -x '*.orig' -x '*.rej' -aur 11.1-1/FreeFileSync/Source/ui/command_box.h 11.1-2/FreeFileSync/Source/ui/command_box.h
--- 11.1-1/FreeFileSync/Source/ui/command_box.h 2020-09-01 19:07:43.719122215 -0400
+++ 11.1-2/FreeFileSync/Source/ui/command_box.h 2020-09-01 20:09:56.840929352 -0400
@@ -145,23 +131,18 @@ diff -x '*.orig' -x '*.rej' -aur 11.1-1/FreeFileSync/Source/ui/folder_history_bo
void setHistory(std::shared_ptr<HistoryList> sharedHistory) { sharedHistory_ = std::move(sharedHistory); }
std::shared_ptr<HistoryList> getHistory() { return sharedHistory_; }
-diff -x '*.orig' -x '*.rej' -aur 11.1-1/FreeFileSync/Source/ui/folder_selector.cpp 11.1-2/FreeFileSync/Source/ui/folder_selector.cpp
---- 11.1-1/FreeFileSync/Source/ui/folder_selector.cpp 2020-09-01 20:07:25.907000676 -0400
-+++ 11.1-2/FreeFileSync/Source/ui/folder_selector.cpp 2020-09-01 20:13:48.791852316 -0400
-@@ -227,9 +227,10 @@
- }
+diff -x '*.orig' -x '*.rej' -aur 11.2-0/FreeFileSync/Source/ui/folder_selector.cpp 11.2-1/FreeFileSync/Source/ui/folder_selector.cpp
+--- 11.2-0/FreeFileSync/Source/ui/folder_selector.cpp 2020-10-02 14:39:05.297463367 -0400
++++ 11.2-1/FreeFileSync/Source/ui/folder_selector.cpp 2020-10-02 15:08:07.066935749 -0400
+@@ -232,7 +232,7 @@
Zstring shellItemPath;
-- wxDirDialog dirPicker(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderPath), wxDD_DEFAULT_STYLE | wxDD_SHOW_HIDDEN);
-- //GTK2: "Show hidden" is also available as a context menu option in the folder picker!
-- //It looks like wxDD_SHOW_HIDDEN only sets the default when opening for the first time!?
-+ wxDirDialog dirPicker(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderPath)); //put modal wxWidgets dialogs on stack: creating on freestore leads to memleak!
-+
-+ //-> following doesn't seem to do anything at all! still "Show hidden" is available as a context menu option:
-+ //::gtk_file_chooser_set_show_hidden(GTK_FILE_CHOOSER(dirPicker.m_widget), true /*show_hidden*/);
-
- if (dirPicker.ShowModal() != wxID_OK)
- return;
+ //default size? Windows: not implemented, Linux(GTK2): not implemented, macOS: not implemented => wxWidgets, what is this shit!?
+- wxDirDialog folderSelector(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderNative), wxDD_DEFAULT_STYLE | wxDD_SHOW_HIDDEN);
++ wxDirDialog folderSelector(parent_, _("Select a folder"), utfTo<wxString>(defaultFolderNative));
+ //GTK2: "Show hidden" is also available as a context menu option in the folder picker!
+ //It looks like wxDD_SHOW_HIDDEN only sets the default when opening for the first time!?
+ if (folderSelector.ShowModal() != wxID_OK)
diff -x '*.orig' -x '*.rej' -aur 11.1-1/wx+/bitmap_button.h 11.1-2/wx+/bitmap_button.h
--- 11.1-1/wx+/bitmap_button.h 2020-09-01 19:07:43.727122311 -0400
+++ 11.1-2/wx+/bitmap_button.h 2020-09-01 20:10:31.385364671 -0400
bgstack15