summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_gcc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_gcc.patch')
-rw-r--r--freefilesync/debian/patches/ffs_gcc.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/freefilesync/debian/patches/ffs_gcc.patch b/freefilesync/debian/patches/ffs_gcc.patch
new file mode 100644
index 0000000..ed007b5
--- /dev/null
+++ b/freefilesync/debian/patches/ffs_gcc.patch
@@ -0,0 +1,46 @@
+diff -Naur 10.25-1/FreeFileSync/Source/Makefile 10.25-2/FreeFileSync/Source/Makefile
+--- 10.25-1/FreeFileSync/Source/Makefile 2020-06-20 13:36:08.495867672 -0400
++++ 10.25-2/FreeFileSync/Source/Makefile 2020-06-20 13:31:36.180419862 -0400
+@@ -1,4 +1,5 @@
+ exeName = FreeFileSync
++CXX=g++-10
+
+ cxxFlags += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+@@ -114,11 +115,11 @@
+
+ ../Build/Bin/$(exeName): $(objFiles)
+ mkdir -p $(dir $@)
+- g++ -o $@ $^ $(linkFlags)
++ $(CXX) -o $@ $^ $(linkFlags)
+
+ $(tmpPath)/ffs/src/%.o : %
+ mkdir -p $(dir $@)
+- g++ $(cxxFlags) -c $< -o $@
++ $(CXX) $(cxxFlags) -c $< -o $@
+
+ clean:
+ rm -rf $(tmpPath)
+diff -Naur 10.25-1/FreeFileSync/Source/RealTimeSync/Makefile 10.25-2/FreeFileSync/Source/RealTimeSync/Makefile
+--- 10.25-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-06-20 13:36:08.499867723 -0400
++++ 10.25-2/FreeFileSync/Source/RealTimeSync/Makefile 2020-06-20 13:31:48.844580205 -0400
+@@ -1,4 +1,5 @@
+ exeName = RealTimeSync
++CXX=g++-10
+
+ cxxFlags += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
+@@ -52,11 +53,11 @@
+
+ ../../Build/Bin/$(exeName): $(objFiles)
+ mkdir -p $(dir $@)
+- g++ -o $@ $^ $(linkFlags)
++ $(CXX) -o $@ $^ $(linkFlags)
+
+ $(tmpPath)/ffs/src/rts/%.o : %
+ mkdir -p $(dir $@)
+- g++ $(cxxFlags) -c $< -o $@
++ $(CXX) $(cxxFlags) -c $< -o $@
+
+ clean:
+ rm -rf $(tmpPath)
bgstack15