summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_devuan_gtk3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_devuan_gtk3.patch')
-rw-r--r--freefilesync/debian/patches/ffs_devuan_gtk3.patch36
1 files changed, 18 insertions, 18 deletions
diff --git a/freefilesync/debian/patches/ffs_devuan_gtk3.patch b/freefilesync/debian/patches/ffs_devuan_gtk3.patch
index 4f41d7a..3559261 100644
--- a/freefilesync/debian/patches/ffs_devuan_gtk3.patch
+++ b/freefilesync/debian/patches/ffs_devuan_gtk3.patch
@@ -7,34 +7,34 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Sou
--- 10.11-0/FreeFileSync/Source/Makefile 2019-04-12 08:05:57.000000000 -0400
+++ 10.18-1/FreeFileSync/Source/Makefile 2019-11-21 09:42:57.408243242 -0500
@@ -16,9 +16,10 @@
- CXXFLAGS += `pkg-config --cflags libssh2`
- LINKFLAGS += `pkg-config --libs libssh2`
+ cxxFlags += `pkg-config --cflags libssh2`
+ linkFlags += `pkg-config --libs libssh2`
--CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-+CXXFLAGS += `pkg-config --cflags gtk+-3.0`
-+LINKFLAGS += `pkg-config --libs gtk+-3.0`
+-cxxFlags += `pkg-config --cflags gtk+-2.0`
++cxxFlags += `pkg-config --cflags gtk+-3.0`
++linkFlags += `pkg-config --libs gtk+-3.0`
#treat as system headers so that warnings are hidden:
--CXXFLAGS += -isystem/usr/include/gtk-2.0
-+CXXFLAGS += -isystem/usr/include/gtk-3.0
+-cxxFlags += -isystem/usr/include/gtk-2.0
++cxxFlags += -isystem/usr/include/gtk-3.0
#support for SELinux (optional)
SELINUX_EXISTING=$(shell pkg-config --exists libselinux && echo YES)
-diff -x '*.rej' -x '*.swp' -x '*.orig' -Naur 10.21-1/FreeFileSync/Source/RealTimeSync/Makefile 10.21-2/FreeFileSync/Source/RealTimeSync/Makefile
---- 10.21-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-03-18 13:12:18.404217783 -0400
-+++ 10.21-2/FreeFileSync/Source/RealTimeSync/Makefile 2020-03-18 13:12:46.528533268 -0400
+diff -x '*.rej' -x '*.orig' -x '*.git*' -Naur 10.24-0/FreeFileSync/Source/RealTimeSync/Makefile 10.24-1/FreeFileSync/Source/RealTimeSync/Makefile
+--- 10.24-0/FreeFileSync/Source/RealTimeSync/Makefile 2020-05-17 18:30:59.289498093 -0400
++++ 10.24-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-05-17 19:32:59.791394275 -0400
@@ -7,9 +7,10 @@
- LINKFLAGS += -s `wx-config --libs std, aui --debug=no` -lz -pthread
+ linkFlags += -s `wx-config --libs std, aui --debug=no` -lz -pthread
#Gtk - support "no button border"
--CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-+CXXFLAGS += `pkg-config --cflags gtk+-3.0`
-+LINKFLAGS += `pkg-config --libs gtk+-3.0`
+-cxxFlags += `pkg-config --cflags gtk+-2.0`
++cxxFlags += `pkg-config --cflags gtk+-3.0`
++linkFlags += `pkg-config --libs gtk+-3.0`
#treat as system headers so that warnings are hidden:
--CXXFLAGS += -isystem/usr/include/gtk-2.0
-+CXXFLAGS += -isystem/usr/include/gtk-3.0
+-cxxFlags += -isystem/usr/include/gtk-2.0
++cxxFlags += -isystem/usr/include/gtk-3.0
- CPP_FILES=
- CPP_FILES+=application.cpp
+ cppFiles=
+ cppFiles+=application.cpp
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/wx+/dc.h 10.18-1/wx+/dc.h
--- 10.18-0/wx+/dc.h 2019-11-21 08:24:23.967769384 -0500
+++ 10.18-1/wx+/dc.h 2019-11-21 09:42:12.779786504 -0500
bgstack15