summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_devuan_gtk3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_devuan_gtk3.patch')
-rw-r--r--freefilesync/debian/patches/ffs_devuan_gtk3.patch27
1 files changed, 14 insertions, 13 deletions
diff --git a/freefilesync/debian/patches/ffs_devuan_gtk3.patch b/freefilesync/debian/patches/ffs_devuan_gtk3.patch
index 6548568..6df123b 100644
--- a/freefilesync/debian/patches/ffs_devuan_gtk3.patch
+++ b/freefilesync/debian/patches/ffs_devuan_gtk3.patch
@@ -1,20 +1,21 @@
Author: B Stack
Source: Original research
-Date: 2020-08-31
+Version: 11.25
+Date: 2020-09-07
Message: Main patch to compile on Devuan using GTK3.
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/Makefile 10.18-1/FreeFileSync/Source/Makefile
---- 10.11-0/FreeFileSync/Source/Makefile 2019-04-12 08:05:57.000000000 -0400
-+++ 10.18-1/FreeFileSync/Source/Makefile 2019-11-21 09:42:57.408243242 -0500
+--- 11.25-0/FreeFileSync/Source/Makefile 2019-04-12 08:05:57.000000000 -0400
++++ 11.25-1/FreeFileSync/Source/Makefile 2019-11-21 09:42:57.408243242 -0500
@@ -16,9 +16,10 @@
cxxFlags += `pkg-config --cflags libssh2`
linkFlags += `pkg-config --libs libssh2`
--cxxFlags += `pkg-config --cflags gtk+-2.0`
-+cxxFlags += `pkg-config --cflags gtk+-3.0`
-+linkFlags += `pkg-config --libs gtk+-3.0`
+-CXXFLAGS += `pkg-config --cflags gtk+-2.0`
++CXXFLAGS += `pkg-config --cflags gtk+-3.0`
++LDFLAGS += `pkg-config --libs gtk+-3.0`
#treat as system headers so that warnings are hidden:
--cxxFlags += -isystem/usr/include/gtk-2.0
-+cxxFlags += -isystem/usr/include/gtk-3.0
+-CXXFLAGS += -isystem/usr/include/gtk-2.0
++CXXFLAGS += -isystem/usr/include/gtk-3.0
#support for SELinux (optional)
SELINUX_EXISTING=$(shell pkg-config --exists libselinux && echo YES)
@@ -25,12 +26,12 @@ diff -x '*.rej' -x '*.orig' -x '*.git*' -Naur 10.24-0/FreeFileSync/Source/RealTi
linkFlags += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -lz -pthread
#Gtk - support "no button border"
--cxxFlags += `pkg-config --cflags gtk+-2.0`
-+cxxFlags += `pkg-config --cflags gtk+-3.0`
-+linkFlags += `pkg-config --libs gtk+-3.0`
+-CXXFLAGS += `pkg-config --cflags gtk+-2.0`
++CXXFLAGS += `pkg-config --cflags gtk+-3.0`
++LDFLAGS += `pkg-config --libs gtk+-3.0`
#treat as system headers so that warnings are hidden:
--cxxFlags += -isystem/usr/include/gtk-2.0
-+cxxFlags += -isystem/usr/include/gtk-3.0
+-CXXFLAGS += -isystem/usr/include/gtk-2.0
++CXXFLAGS += -isystem/usr/include/gtk-3.0
cppFiles=
cppFiles+=application.cpp
bgstack15