summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_devuan_gtk2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_devuan_gtk2.patch')
-rw-r--r--freefilesync/debian/patches/ffs_devuan_gtk2.patch71
1 files changed, 6 insertions, 65 deletions
diff --git a/freefilesync/debian/patches/ffs_devuan_gtk2.patch b/freefilesync/debian/patches/ffs_devuan_gtk2.patch
index 1a79546..f3242b3 100644
--- a/freefilesync/debian/patches/ffs_devuan_gtk2.patch
+++ b/freefilesync/debian/patches/ffs_devuan_gtk2.patch
@@ -1,36 +1,10 @@
Author: B Stack
Source: Original research
Date: 2019-11-21
-Message: Main patch to compile on Devuan.
-diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/base/ffs_paths.cpp 10.18-1/FreeFileSync/Source/base/ffs_paths.cpp
---- 10.13-0/FreeFileSync/Source/base/ffs_paths.cpp 2019-06-14 20:23:07.615661499 -0400
-+++ 10.18-1/FreeFileSync/Source/base/ffs_paths.cpp 2019-11-21 09:41:42.287474472 -0500
-@@ -64,7 +64,8 @@
-
- Zstring fff::getResourceDirPf()
- {
-- return getProcessParentFolderPath() + FILE_NAME_SEPARATOR + Zstr("Resources") + FILE_NAME_SEPARATOR;
-+ // For Fedora, EL and Devuan, install to /usr/share/freefilesync specificly
-+ return Zstr("/usr/share/freefilesync/");
- }
-
-
+Message: Patches to use gtk2. Depends on ffs_devuan.patch
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/Makefile 10.18-1/FreeFileSync/Source/Makefile
--- 10.11-0/FreeFileSync/Source/Makefile 2019-04-12 08:05:57.000000000 -0400
+++ 10.18-2/FreeFileSync/Source/Makefile 2019-11-21 09:42:57.408243242 -0500
-@@ -1,10 +1,10 @@
--EXENAME = FreeFileSync_$(shell arch)
-+EXENAME = FreeFileSync
-
- CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
- -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
- -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
-
--LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
-
-
- CXXFLAGS += `pkg-config --cflags openssl`
@@ -16,9 +16,10 @@
CXXFLAGS += `pkg-config --cflags libssh2`
LINKFLAGS += `pkg-config --libs libssh2`
@@ -44,47 +18,14 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Sou
#support for SELinux (optional)
SELINUX_EXISTING=$(shell pkg-config --exists libselinux && echo YES)
-@@ -84,6 +85,7 @@
- CPP_FILES+=../../zen/file_io.cpp
- CPP_FILES+=../../zen/file_traverser.cpp
- CPP_FILES+=../../zen/http.cpp
-+CPP_FILES+=../../zen/system.cpp
- CPP_FILES+=../../zen/zstring.cpp
- CPP_FILES+=../../zen/format_unit.cpp
- CPP_FILES+=../../zen/legacy_compiler.cpp
diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/RealTimeSync/Makefile 10.18-1/FreeFileSync/Source/RealTimeSync/Makefile
---- 10.11-0/FreeFileSync/Source/RealTimeSync/Makefile 2019-04-12 08:05:57.000000000 -0400
-+++ 10.18-2/FreeFileSync/Source/RealTimeSync/Makefile 2019-11-21 09:46:11.378240094 -0500
-@@ -1,15 +1,16 @@
--EXENAME = RealTimeSync_$(shell arch)
-+EXENAME = RealTimeSync
-
- CXXFLAGS = -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
- -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
- -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
-
--LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+--- 10.20-0/FreeFileSync/Source/RealTimeSync/Makefile 2020-02-15 11:45:58.241515736 -0500
++++ 10.20-1/FreeFileSync/Source/RealTimeSync/Makefile 2020-02-15 15:43:32.852203730 -0500
+@@ -8,6 +8,7 @@
#Gtk - support "no button border"
--CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-+CXXFLAGS += `pkg-config --cflags gtk+-2.0`
+ CXXFLAGS += `pkg-config --cflags gtk+-2.0`
+LINKFLAGS += `pkg-config --libs gtk+-2.0`
#treat as system headers so that warnings are hidden:
--CXXFLAGS += -isystem/usr/include/gtk-2.0
-+CXXFLAGS += -isystem/usr/include/gtk-2.0
-
- CPP_FILES=
- CPP_FILES+=application.cpp
-diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.19-0/FreeFileSync/Source/ui/small_dlgs.cpp 10.19-1/FreeFileSync/Source/ui/small_dlgs.cpp
---- 10.11-0/FreeFileSync/Source/ui/small_dlgs.cpp 2019-12-27 07:56:06.714625467 -0500
-+++ 10.19-1/FreeFileSync/Source/ui/small_dlgs.cpp 2019-12-27 08:56:49.251467477 -0500
-@@ -95,6 +95,8 @@
- build += L"64 Bit";
- #endif
-
-+ build += L" for Devuan";
-+
- build += SPACED_BULLET;
- build += formatTime<wxString>(FORMAT_DATE, getCompileTime());
+ CXXFLAGS += -isystem/usr/include/gtk-2.0
bgstack15