summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_devuan.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_devuan.patch')
-rw-r--r--freefilesync/debian/patches/ffs_devuan.patch87
1 files changed, 28 insertions, 59 deletions
diff --git a/freefilesync/debian/patches/ffs_devuan.patch b/freefilesync/debian/patches/ffs_devuan.patch
index 06de345..de2bd20 100644
--- a/freefilesync/debian/patches/ffs_devuan.patch
+++ b/freefilesync/debian/patches/ffs_devuan.patch
@@ -1,12 +1,11 @@
Author: bgstack15
Source: Original research
-Last-Modified: 2022-05-22
-Last-Version: 11.21
+Last-Modified: 2022-08-03
+Last-Version: 11.23
Message: Main patch to compile on Devuan.
-diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Source/ffs_paths.cpp 10.18-1/FreeFileSync/Source/ffs_paths.cpp
---- 10.13-0/FreeFileSync/Source/ffs_paths.cpp 2019-06-14 20:23:07.615661499 -0400
-+++ 11.21-1/FreeFileSync/Source/ffs_paths.cpp 2019-11-21 09:41:42.287474472 -0500
-@@ -49,7 +49,7 @@
+--- a/FreeFileSync/Source/ffs_paths.cpp
++++ b/FreeFileSync/Source/ffs_paths.cpp
+@@ -49,7 +49,7 @@ Zstring fff::getInstallDirPath()
Zstring fff::getResourceDirPath()
{
@@ -15,9 +14,8 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.18-0/FreeFileSync/Sou
}
-diff -Naur -x '*.orig' -x '*.rej' -x .git 11.4-0/FreeFileSync/Source/Makefile 11.4-1/FreeFileSync/Source/Makefile
---- 11.20-0/FreeFileSync/Source/Makefile 2022-04-18 09:49:31.901386387 -0400
-+++ 11.20-1/FreeFileSync/Source/Makefile 2022-04-18 10:00:41.504569833 -0400
+--- a/FreeFileSync/Source/Makefile
++++ b/FreeFileSync/Source/Makefile
@@ -1,10 +1,10 @@
-exeName = FreeFileSync_$(shell arch)
+exeName = FreeFileSync
@@ -32,10 +30,9 @@ diff -Naur -x '*.orig' -x '*.rej' -x .git 11.4-0/FreeFileSync/Source/Makefile 11
cxxFlags += `pkg-config --cflags openssl`
-diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.19-0/FreeFileSync/Source/ui/small_dlgs.cpp 11.12-1/FreeFileSync/Source/ui/small_dlgs.cpp
---- 10.11-0/FreeFileSync/Source/ui/small_dlgs.cpp 2019-12-27 07:56:06.714625467 -0500
-+++ 11.12-1/FreeFileSync/Source/ui/small_dlgs.cpp 2021-07-15 09:03:57.753183052 -0400
-@@ -93,6 +93,8 @@
+--- a/FreeFileSync/Source/ui/small_dlgs.cpp
++++ b/FreeFileSync/Source/ui/small_dlgs.cpp
+@@ -89,6 +89,8 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
build += LTR_MARK; //fix Arabic
build += utfTo<wxString>(cpuArchName);
@@ -44,51 +41,7 @@ diff -x '*.swp' -x '.git*' -x '*.orig' -x '*.rej' -Naur 10.19-0/FreeFileSync/Sou
build += SPACED_BULLET;
build += utfTo<wxString>(formatTime(formatDateTag, getCompileTime()));
-diff -Naur -x '*.orig' -x '*.rej' -x .git 11.4-0/FreeFileSync/Source/RealTimeSync/Makefile 11.4-1/FreeFileSync/Source/RealTimeSync/Makefile
---- 11.20-0/FreeFileSync/Source/RealTimeSync/Makefile 2022-04-18 09:49:31.901386387 -0400
-+++ 11.20-1/FreeFileSync/Source/RealTimeSync/Makefile 2022-04-18 10:00:35.168501749 -0400
-@@ -1,10 +1,10 @@
--exeName = RealTimeSync_$(shell arch)
-+exeName = RealTimeSync
-
--cxxFlags = -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-+cxxFlags += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
- -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
- -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
-
--linkFlags = -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread
-+linkFlags += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -lz -pthread
-
- #Gtk - support "no button border"
- cxxFlags += `pkg-config --cflags gtk+-2.0`
-Message: Fix some sloppiness by Zenju.
-diff -Naur -x '*.orig' -x '*.rej' -x .git 11.21-0/FreeFileSync/Source/application.cpp 11.21-1/FreeFileSync/Source/application.cpp
---- 11.21-0/FreeFileSync/Source/application.cpp 2022-05-22 17:09:32.234809499 -0400
-+++ 11.21-1/FreeFileSync/Source/application.cpp 2022-05-24 08:36:51.949159500 -0400
-@@ -92,7 +92,7 @@
- ZEN_ON_SCOPE_EXIT(if (error) ::g_error_free(error));
-
- ::gtk_css_provider_load_from_path(provider, //GtkCssProvider* css_provider,
-- (getResourceDirPf() + fileName).c_str(), //const gchar* path,
-+ (getResourceDirPath() + fileName).c_str(), //const gchar* path,
- &error); //GError** error
- if (error)
- throw SysError(formatGlibError("gtk_css_provider_load_from_path", error));
---- 11.21-0/FreeFileSync/Source/RealTimeSync/application.cpp 2022-05-22 17:09:32.226809398 -0400
-+++ 11.21-1/FreeFileSync/Source/RealTimeSync/application.cpp 2022-05-25 09:15:00.262617987 -0400
-@@ -68,7 +68,7 @@
- ZEN_ON_SCOPE_EXIT(if (error) ::g_error_free(error));
-
- ::gtk_css_provider_load_from_path(provider, //GtkCssProvider* css_provider,
-- (fff::getResourceDirPf() + fileName).c_str(), //const gchar* path,
-+ (fff::getResourceDirPath() + fileName).c_str(), //const gchar* path,
- &error); //GError** error
- if (error)
- throw SysError(formatGlibError("gtk_css_provider_load_from_path", error));
-Message: some random sloppiness with a missing graphical asset. It's not important to the application.
---- 11.22-0/FreeFileSync/Source/ui/small_dlgs.cpp 2022-06-26 16:03:49.887270966 -0400
-+++ 11.22-1/FreeFileSync/Source/ui/small_dlgs.cpp 2022-06-26 16:03:52.123298767 -0400
-@@ -140,9 +140,9 @@
+@@ -139,9 +141,9 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
wxImage::AddHandler(new wxJPEGHandler /*ownership passed*/); //activate support for .jpg files
@@ -101,7 +54,7 @@ Message: some random sloppiness with a missing graphical asset. It's not importa
//--------------------------------------------------------------------------
//have animal + text match *final* dialog width
-@@ -152,7 +152,7 @@
+@@ -151,7 +153,7 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
const int imageWidth = (m_panelDonate->GetSize().GetWidth() - 5 - 5 /* grey border*/) / 2;
const int textWidth = m_panelDonate->GetSize().GetWidth() - 5 - 5 - imageWidth;
@@ -110,3 +63,19 @@ Message: some random sloppiness with a missing graphical asset. It's not importa
m_staticTextDonate->Show();
m_staticTextDonate->Wrap(textWidth - 10 /*left gap*/); //wrap *after* changing font size
+--- a/FreeFileSync/Source/RealTimeSync/Makefile
++++ b/FreeFileSync/Source/RealTimeSync/Makefile
+@@ -1,10 +1,10 @@
+-exeName = RealTimeSync_$(shell arch)
++exeName = RealTimeSync
+
+-cxxFlags = -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
++cxxFlags += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ -Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
+ -O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
+
+-linkFlags = -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread
++linkFlags += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -lz -pthread
+
+ #Gtk - support "no button border"
+ cxxFlags += `pkg-config --cflags gtk+-2.0`
bgstack15