summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_devuan.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_devuan.patch')
-rw-r--r--freefilesync/debian/patches/ffs_devuan.patch19
1 files changed, 9 insertions, 10 deletions
diff --git a/freefilesync/debian/patches/ffs_devuan.patch b/freefilesync/debian/patches/ffs_devuan.patch
index fce3138..d51f2fc 100644
--- a/freefilesync/debian/patches/ffs_devuan.patch
+++ b/freefilesync/debian/patches/ffs_devuan.patch
@@ -14,8 +14,8 @@ Message: Main patch to compile on Devuan.
}
---- 11.25-0/FreeFileSync/Source/Makefile 2022-09-07 14:54:31.444628869 -0400
-+++ 11.25-1/FreeFileSync/Source/Makefile 2022-09-07 15:15:48.735015001 -0400
+--- a/FreeFileSync/Source/Makefile
++++ b/FreeFileSync/Source/Makefile
@@ -1,11 +1,11 @@
CXX ?= g++
-exeName = FreeFileSync_$(shell arch)
@@ -32,7 +32,7 @@ Message: Main patch to compile on Devuan.
CXXFLAGS += `pkg-config --cflags openssl`
--- a/FreeFileSync/Source/ui/small_dlgs.cpp
+++ b/FreeFileSync/Source/ui/small_dlgs.cpp
-@@ -89,6 +89,8 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
+@@ -87,6 +87,8 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
build += LTR_MARK; //fix Arabic
build += utfTo<wxString>(cpuArchName);
@@ -41,7 +41,7 @@ Message: Main patch to compile on Devuan.
build += SPACED_BULLET;
build += utfTo<wxString>(formatTime(formatDateTag, getCompileTime()));
-@@ -139,9 +141,9 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
+@@ -137,9 +139,9 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
wxImage::AddHandler(new wxJPEGHandler /*ownership passed*/); //activate support for .jpg files
@@ -54,17 +54,17 @@ Message: Main patch to compile on Devuan.
//--------------------------------------------------------------------------
//have animal + text match *final* dialog width
-@@ -151,7 +153,7 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
- const int imageWidth = (m_panelDonate->GetSize().GetWidth() - 5 - 5 /* grey border*/) / 2;
- const int textWidth = m_panelDonate->GetSize().GetWidth() - 5 - 5 - imageWidth;
+@@ -149,7 +151,7 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
+ const int imageWidth = (m_panelDonate->GetSize().GetWidth() - 5 - 5 - 5 /* grey border*/) / 2;
+ const int textWidth = m_panelDonate->GetSize().GetWidth() - 5 - 5 - 5 - imageWidth;
- setImage(*m_bitmapAnimalSmall, shrinkImage(animalImg, imageWidth, -1 /*maxHeight*/));
+ //setImage(*m_bitmapAnimalSmall, shrinkImage(animalImg, imageWidth, -1 /*maxHeight*/));
m_staticTextDonate->Show();
m_staticTextDonate->Wrap(textWidth - 10 /*left gap*/); //wrap *after* changing font size
---- 11.25-0/FreeFileSync/Source/RealTimeSync/Makefile 2022-09-07 14:54:31.524629769 -0400
-+++ 11.25-1/FreeFileSync/Source/RealTimeSync/Makefile 2022-09-07 15:16:18.479350210 -0400
+--- a/FreeFileSync/Source/RealTimeSync/Makefile
++++ b/FreeFileSync/Source/RealTimeSync/Makefile
@@ -1,11 +1,11 @@
CXX ?= g++
-exeName = RealTimeSync_$(shell arch)
@@ -79,4 +79,3 @@ Message: Main patch to compile on Devuan.
#Gtk - support "no button border"
CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-
bgstack15