summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_devuan.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_devuan.patch')
-rw-r--r--freefilesync/debian/patches/ffs_devuan.patch37
1 files changed, 19 insertions, 18 deletions
diff --git a/freefilesync/debian/patches/ffs_devuan.patch b/freefilesync/debian/patches/ffs_devuan.patch
index de2bd20..fce3138 100644
--- a/freefilesync/debian/patches/ffs_devuan.patch
+++ b/freefilesync/debian/patches/ffs_devuan.patch
@@ -1,7 +1,7 @@
Author: bgstack15
Source: Original research
-Last-Modified: 2022-08-03
-Last-Version: 11.23
+Last-Modified: 2022-09-07
+Last-Version: 11.25
Message: Main patch to compile on Devuan.
--- a/FreeFileSync/Source/ffs_paths.cpp
+++ b/FreeFileSync/Source/ffs_paths.cpp
@@ -14,22 +14,22 @@ Message: Main patch to compile on Devuan.
}
---- a/FreeFileSync/Source/Makefile
-+++ b/FreeFileSync/Source/Makefile
-@@ -1,10 +1,10 @@
+--- 11.25-0/FreeFileSync/Source/Makefile 2022-09-07 14:54:31.444628869 -0400
++++ 11.25-1/FreeFileSync/Source/Makefile 2022-09-07 15:15:48.735015001 -0400
+@@ -1,11 +1,11 @@
+ CXX ?= g++
-exeName = FreeFileSync_$(shell arch)
+exeName = FreeFileSync
--cxxFlags = -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-+cxxFlags += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ CXXFLAGS += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
--linkFlags = -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread
-+linkFlags += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -lz -pthread
+-LDFLAGS += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread
++LDFLAGS += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread -lz
- cxxFlags += `pkg-config --cflags openssl`
+ CXXFLAGS += `pkg-config --cflags openssl`
--- a/FreeFileSync/Source/ui/small_dlgs.cpp
+++ b/FreeFileSync/Source/ui/small_dlgs.cpp
@@ -89,6 +89,8 @@ AboutDlg::AboutDlg(wxWindow* parent) : A
@@ -63,19 +63,20 @@ Message: Main patch to compile on Devuan.
m_staticTextDonate->Show();
m_staticTextDonate->Wrap(textWidth - 10 /*left gap*/); //wrap *after* changing font size
---- a/FreeFileSync/Source/RealTimeSync/Makefile
-+++ b/FreeFileSync/Source/RealTimeSync/Makefile
-@@ -1,10 +1,10 @@
+--- 11.25-0/FreeFileSync/Source/RealTimeSync/Makefile 2022-09-07 14:54:31.524629769 -0400
++++ 11.25-1/FreeFileSync/Source/RealTimeSync/Makefile 2022-09-07 15:16:18.479350210 -0400
+@@ -1,11 +1,11 @@
+ CXX ?= g++
-exeName = RealTimeSync_$(shell arch)
+exeName = RealTimeSync
--cxxFlags = -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-+cxxFlags += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ CXXFLAGS += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
--linkFlags = -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread
-+linkFlags += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -lz -pthread
+-LDFLAGS += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread
++LDFLAGS += -s -no-pie `wx-config --libs std, aui, richtext --debug=no` -pthread -lz
#Gtk - support "no button border"
- cxxFlags += `pkg-config --cflags gtk+-2.0`
+ CXXFLAGS += `pkg-config --cflags gtk+-2.0`
+
bgstack15