summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_desktop_notifications.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_desktop_notifications.patch')
-rw-r--r--freefilesync/debian/patches/ffs_desktop_notifications.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/freefilesync/debian/patches/ffs_desktop_notifications.patch b/freefilesync/debian/patches/ffs_desktop_notifications.patch
index b660044..a262682 100644
--- a/freefilesync/debian/patches/ffs_desktop_notifications.patch
+++ b/freefilesync/debian/patches/ffs_desktop_notifications.patch
@@ -1,5 +1,5 @@
-Version: 12.1
-Date: 2023-02-21
+Version: 12.5
+Date: 2023-07-25
Author: bgstack15
Message: Add support for building with desktop notification support.
--- a/FreeFileSync/Source/Makefile
@@ -8,7 +8,7 @@ Message: Add support for building with desktop notification support.
#treat as system headers so that warnings are hidden:
CXXFLAGS += -isystem/usr/include/gtk-3.0
-+with_notifications ?= NO
++with_notifications ?= YES
+ifeq ($(with_notifications),YES)
+# package libglibmm-2.4-dev or glibmm24-devel
+cxxFlags += `pkg-config --cflags giomm-2.4` -Dwith_notifications
@@ -20,7 +20,7 @@ Message: Add support for building with desktop notification support.
ifeq ($(SELINUX_EXISTING),YES)
--- a/FreeFileSync/Source/ui/progress_indicator.cpp
+++ b/FreeFileSync/Source/ui/progress_indicator.cpp
-@@ -30,6 +30,9 @@
+@@ -29,6 +29,9 @@
#include "../icon_buffer.h"
#include "../base/speed_test.h"
@@ -30,8 +30,8 @@ Message: Add support for building with desktop notification support.
using namespace zen;
using namespace fff;
-@@ -1368,6 +1371,22 @@ void SyncProgressDialogImpl<TopLevelDial
- pnl_.m_staticTextPhase->SetLabelText(getSyncResultLabel(syncResult));
+@@ -1439,6 +1442,22 @@ void SyncProgressDialogImpl<TopLevelDial
+
//pnl_.m_bitmapStatus->SetToolTip(); -> redundant
+#ifdef with_notifications
bgstack15