summaryrefslogtreecommitdiff
path: root/xseticon/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-02-11 07:56:52 -0500
committerB Stack <bgstack15@gmail.com>2020-02-11 07:56:52 -0500
commit1168540bf4cfb872183951b27cd4b67f962adedc (patch)
tree8a760ba9fa873364dc560ddea73068a33c5a73ef /xseticon/debian/rules
parentWIP: add mktrayicon (diff)
downloadstackrpms-1168540bf4cfb872183951b27cd4b67f962adedc.tar.gz
stackrpms-1168540bf4cfb872183951b27cd4b67f962adedc.tar.bz2
stackrpms-1168540bf4cfb872183951b27cd4b67f962adedc.zip
add dpkg for xseticon
Diffstat (limited to 'xseticon/debian/rules')
-rwxr-xr-xxseticon/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/xseticon/debian/rules b/xseticon/debian/rules
new file mode 100755
index 0000000..c8c6c34
--- /dev/null
+++ b/xseticon/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ dh_auto_build
+ # Future improvement: help2man xseticon > debian/xseticon.1
+override_dh_auto_install:
+ dh_auto_install -- PREFIX=debian/xseticon/usr
+
+#override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo
bgstack15