summaryrefslogtreecommitdiff
path: root/xseticon/debian/patches
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-02-11 07:56:52 -0500
committerB Stack <bgstack15@gmail.com>2020-02-11 07:56:52 -0500
commit1168540bf4cfb872183951b27cd4b67f962adedc (patch)
tree8a760ba9fa873364dc560ddea73068a33c5a73ef /xseticon/debian/patches
parentWIP: add mktrayicon (diff)
downloadstackrpms-1168540bf4cfb872183951b27cd4b67f962adedc.tar.gz
stackrpms-1168540bf4cfb872183951b27cd4b67f962adedc.tar.bz2
stackrpms-1168540bf4cfb872183951b27cd4b67f962adedc.zip
add dpkg for xseticon
Diffstat (limited to 'xseticon/debian/patches')
-rw-r--r--xseticon/debian/patches/Makefile.patch17
-rw-r--r--xseticon/debian/patches/series2
2 files changed, 19 insertions, 0 deletions
diff --git a/xseticon/debian/patches/Makefile.patch b/xseticon/debian/patches/Makefile.patch
new file mode 100644
index 0000000..b5b4279
--- /dev/null
+++ b/xseticon/debian/patches/Makefile.patch
@@ -0,0 +1,17 @@
+Date: 2020-02-10
+Author: bgstack15
+Notes: The order of flags matters to gcc on Devuan. Fedora did not need this the same way.
+References:
+Web search "undefined reference to `XAllowEvents"
+https://github.com/aktau/hhpc/commit/1c97ac2c69abf475af9746e0dc31170e0ee9b00b
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ xseticon.o: xseticon.c
+ gcc ${GLIB_CFLAGS} ${XLIB_CFLAGS} -c $^ -o $@
+
+ xseticon: xseticon.o
+- gcc ${LIBS} $^ -o $@
++ gcc $^ -o $@ ${LIBS}
+
+ .PHONY: clean
+ clean:
diff --git a/xseticon/debian/patches/series b/xseticon/debian/patches/series
new file mode 100644
index 0000000..cc55c1d
--- /dev/null
+++ b/xseticon/debian/patches/series
@@ -0,0 +1,2 @@
+# You must remove unused comment lines for the released package.
+Makefile.patch
bgstack15