summaryrefslogtreecommitdiff
path: root/xseticon/debian/patches/Makefile.patch
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-02-12 00:43:00 +0000
committerB Stack <bgstack15@gmail.com>2020-02-12 00:43:00 +0000
commit69001f6e35ac4d49d6ceab76344854fa77e808e2 (patch)
treeae20854b6feb039bcc7f92c145b7ff264f1d9130 /xseticon/debian/patches/Makefile.patch
parentMerge branch 'xdg-themes-stackrpms-bump' into 'master' (diff)
parentadd xdgmenumaker-user script and menu entry (diff)
downloadstackrpms-69001f6e35ac4d49d6ceab76344854fa77e808e2.tar.gz
stackrpms-69001f6e35ac4d49d6ceab76344854fa77e808e2.tar.bz2
stackrpms-69001f6e35ac4d49d6ceab76344854fa77e808e2.zip
Merge branch 'updates' into 'master'
veracrypt, xdgmenumaker, ublock-origin, notepadpp, palemoon, xseticon dpkg Closes #16 See merge request bgstack15/stackrpms!122
Diffstat (limited to 'xseticon/debian/patches/Makefile.patch')
-rw-r--r--xseticon/debian/patches/Makefile.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/xseticon/debian/patches/Makefile.patch b/xseticon/debian/patches/Makefile.patch
new file mode 100644
index 0000000..b5b4279
--- /dev/null
+++ b/xseticon/debian/patches/Makefile.patch
@@ -0,0 +1,17 @@
+Date: 2020-02-10
+Author: bgstack15
+Notes: The order of flags matters to gcc on Devuan. Fedora did not need this the same way.
+References:
+Web search "undefined reference to `XAllowEvents"
+https://github.com/aktau/hhpc/commit/1c97ac2c69abf475af9746e0dc31170e0ee9b00b
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ xseticon.o: xseticon.c
+ gcc ${GLIB_CFLAGS} ${XLIB_CFLAGS} -c $^ -o $@
+
+ xseticon: xseticon.o
+- gcc ${LIBS} $^ -o $@
++ gcc $^ -o $@ ${LIBS}
+
+ .PHONY: clean
+ clean:
bgstack15