summaryrefslogtreecommitdiff
path: root/xdgmenumaker/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-01-13 14:14:10 +0000
committerB Stack <bgstack15@gmail.com>2020-01-13 14:14:10 +0000
commita63b8381490cfad4df5b9f4677954dcff92b480f (patch)
treec6862acd465d9270c68cfc47918f36e08a10d77b /xdgmenumaker/debian/rules
parentimprove debian/watch files for many packages (diff)
parentadd dpkg-trigger function to xdgmenumaker (diff)
downloadstackrpms-a63b8381490cfad4df5b9f4677954dcff92b480f.tar.gz
stackrpms-a63b8381490cfad4df5b9f4677954dcff92b480f.tar.bz2
stackrpms-a63b8381490cfad4df5b9f4677954dcff92b480f.zip
Merge branch 'xdgmenumaker-bump' into 'master'
add xdgmenumaker See merge request bgstack15/stackrpms!113
Diffstat (limited to 'xdgmenumaker/debian/rules')
-rwxr-xr-xxdgmenumaker/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/xdgmenumaker/debian/rules b/xdgmenumaker/debian/rules
new file mode 100755
index 0000000..8904aab
--- /dev/null
+++ b/xdgmenumaker/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install -- PREFIX=/usr
+
+#override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo
+
+# Not working, but a good idea. Reference: https://phabricator.wikimedia.org/D463
+#override_dh_auto_python:
+# dh_python3 --shebang=/usr/bin/python3
+
+override_dh_auto_test:
+ echo skip tests because output depends on locally-installed icon files existing
bgstack15