summaryrefslogtreecommitdiff
path: root/xdgmenumaker/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-01-05 09:46:03 -0500
committerB Stack <bgstack15@gmail.com>2020-01-05 09:46:03 -0500
commit177175f8e1485120847250573b2b4babdb7a2e65 (patch)
treeec2e478f5909e75b477d8427fddaf909eb58209a /xdgmenumaker/debian/rules
parentimprove debian/watch files for many packages (diff)
downloadstackrpms-177175f8e1485120847250573b2b4babdb7a2e65.tar.gz
stackrpms-177175f8e1485120847250573b2b4babdb7a2e65.tar.bz2
stackrpms-177175f8e1485120847250573b2b4babdb7a2e65.zip
add xdgmenumaker, at v 1.5
Diffstat (limited to 'xdgmenumaker/debian/rules')
-rwxr-xr-xxdgmenumaker/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/xdgmenumaker/debian/rules b/xdgmenumaker/debian/rules
new file mode 100755
index 0000000..8904aab
--- /dev/null
+++ b/xdgmenumaker/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install -- PREFIX=/usr
+
+#override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo
+
+# Not working, but a good idea. Reference: https://phabricator.wikimedia.org/D463
+#override_dh_auto_python:
+# dh_python3 --shebang=/usr/bin/python3
+
+override_dh_auto_test:
+ echo skip tests because output depends on locally-installed icon files existing
bgstack15