summaryrefslogtreecommitdiff
path: root/veracrypt/debian
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2023-10-03 20:11:50 -0400
committerB. Stack <bgstack15@gmail.com>2023-10-03 20:11:50 -0400
commit2e9f0a169debcd4a507bff1931c6be57c894b5b8 (patch)
tree8d2d3cbaf591ee4f812e2280da373d98e042032b /veracrypt/debian
parentMerge branch 'freefilesync-bump' (diff)
downloadstackrpms-2e9f0a169debcd4a507bff1931c6be57c894b5b8.tar.gz
stackrpms-2e9f0a169debcd4a507bff1931c6be57c894b5b8.tar.bz2
stackrpms-2e9f0a169debcd4a507bff1931c6be57c894b5b8.zip
vc 1.26.7 rc1
Diffstat (limited to 'veracrypt/debian')
-rw-r--r--veracrypt/debian/_service4
-rw-r--r--veracrypt/debian/changelog41
-rw-r--r--veracrypt/debian/patches/1001-port-to-libfuse3.patch36
-rw-r--r--veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch33
-rw-r--r--veracrypt/debian/patches/series1
-rw-r--r--veracrypt/debian/patches/vc_devuan.patch27
-rw-r--r--veracrypt/debian/veracrypt+stackrpms.dsc2
7 files changed, 108 insertions, 36 deletions
diff --git a/veracrypt/debian/_service b/veracrypt/debian/_service
index 8ac2e34..f35bf13 100644
--- a/veracrypt/debian/_service
+++ b/veracrypt/debian/_service
@@ -1,7 +1,7 @@
<services>
<service name="tar_scm">
<param name="scm">git</param>
- <param name="url">https://bgstack15.ddns.net/cgit/stackrpms</param>
+ <param name="url">https://gitlab.com/bgstack15/stackrpms.git</param>
<param name="subdir">veracrypt/debian</param>
<param name="filename">debian</param>
<param name="revision">veracrypt-bump</param>
@@ -14,7 +14,7 @@
<service name="tar_scm">
<param name="scm">git</param>
<param name="url">https://github.com/veracrypt/VeraCrypt.git</param>
- <param name="revision">VeraCrypt_1.25.9</param>
+ <param name="revision">VeraCrypt_1.26.7</param>
<param name="version">_none_</param>
</service>
<service name="recompress">
diff --git a/veracrypt/debian/changelog b/veracrypt/debian/changelog
index 480b8ee..ce42bbd 100644
--- a/veracrypt/debian/changelog
+++ b/veracrypt/debian/changelog
@@ -1,3 +1,44 @@
+veracrypt (1.26.7-1+stackrpms) obs; urgency=low
+
+ * All OSes:
+ * Security: Ensure that XTS primary key is different from the secondary key when creating volumes
+ * Issue unlikely to happen thanks to random generator properties but this check must be added to prevent attacks
+ * Reference: CCSS,NSA comment at page 3: https://csrc.nist.gov/csrc/media/Projects/crypto-publication-review-project/documents/initial-comments/sp800-38e-initial-public-comments-2021.pdf
+ * Remove TrueCrypt Mode support. Version 1.25.9 can be used to mount or convert TrueCrypt volumes.
+ * Complete removal of RIPEMD160 and GOST89 algorithms. Legacy volumes using any of them cannot be mounted by VeraCrypt anymore.
+ * Add support for BLAKE2s as new PRF algorithm for both system encryption and standard volumes.
+ * Introducing support for EMV banking smart cards as keyfiles for non-system volumes.
+ * No need for a separate PKCS#11 module configuration.
+ * Card PIN isn't required.
+ * Generates secure keyfile content from unique, encoded data present on the banking card.
+ * Supports all EMV standard-compliant banking cards.
+ * Can be enabled in settings (go to Settings->Security Tokens).
+ * Developed by a team of students from the Institut national des sciences appliquées de Rennes.
+ * More details about the team and the project are available at https://projets-info.insa-rennes.fr/projets/2022/VeraCrypt/index_en.html.
+ * When overwriting an existing file container during volume creation, add its current size to the available free space
+ * Add Corsican language support. Update several translations.
+ * Update documentation
+ * Linux:
+ * Fix bug in Random generator on Linux when used with Blake2s that was triggering a self test failure.
+ * Modify Random Generator on Linux to exactly match official documentation and the Windows implementation.
+ * Fix compatibility issues with Ubuntu 23.04.
+ * Fix assert messages displayed when using wxWidgets 3.1.6 and newer.
+ * Fix issues launching fsck on Linux.
+ * Fix privilege escalation prompts being ignored.
+ * Fix wrong size for hidden volume when selecting the option to use all free space.
+ * Fix failure to create hidden volume on a disk using CLI caused by wrong maximum size detection.
+ * Fix various issues when running in Text mode:
+ * Don't allow selecting exFAT/BTRFS filesytem if they are not present or not compatible with the created volume.
+ * Fix wrong dismount message displayed when mounting a volume.
+ * Hide PIM during entry and re-ask PIM when user entered a wrong value.
+ * Fix printing error when checking free space during volume creation in path doesn't exist.
+ * Use wxWidgets 3.2.2.1 for static builds (e.g. console only version)
+ * Fix compatibility of generic installers with old Linux distros
+ * Update help message to indicate that when cascading algorithms they must be separated by dash
+ * Better compatibility with building under Alpine Linux and musl libc
+
+ -- B. Stack <bgstack15@gmail.com> Tue, 03 Oct 2023 19:56:45 -0400
+
veracrypt (1.25.9-3+stackrpms) obs; urgency=low
* Dpkg updates
diff --git a/veracrypt/debian/patches/1001-port-to-libfuse3.patch b/veracrypt/debian/patches/1001-port-to-libfuse3.patch
index 9325f08..5f2860e 100644
--- a/veracrypt/debian/patches/1001-port-to-libfuse3.patch
+++ b/veracrypt/debian/patches/1001-port-to-libfuse3.patch
@@ -8,29 +8,29 @@ Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
src/Main/Main.make | 2 +-
3 files changed, 11 insertions(+), 19 deletions(-)
---- a/src/Main/Main.make 2021-10-07 03:51:22.964715592 -0400
-+++ b/src/Main/Main.make 2021-10-07 03:51:22.948715727 -0400
-@@ -102,7 +102,7 @@
+--- a/src/Main/Main.make
++++ b/src/Main/Main.make
+@@ -102,7 +102,7 @@ endif
#------ FUSE configuration ------
--FUSE_LIBS = $(shell pkg-config fuse --libs)
-+FUSE_LIBS = $(shell pkg-config fuse3 --libs)
+-FUSE_LIBS = $(shell $(PKG_CONFIG) fuse --libs)
++FUSE_LIBS = $(shell $(PKG_CONFIG) fuse3 --libs)
#------ Executable ------
---- a/src/Driver/Fuse/Driver.make 2021-10-07 03:51:22.964715592 -0400
-+++ b/src/Driver/Fuse/Driver.make 2021-10-07 03:51:22.948715727 -0400
-@@ -15,6 +15,6 @@
+--- a/src/Driver/Fuse/Driver.make
++++ b/src/Driver/Fuse/Driver.make
+@@ -15,6 +15,6 @@ NAME := Driver
OBJS :=
OBJS += FuseService.o
--CXXFLAGS += $(shell pkg-config fuse --cflags)
-+CXXFLAGS += $(shell pkg-config fuse3 --cflags)
+-CXXFLAGS += $(shell $(PKG_CONFIG) fuse --cflags)
++CXXFLAGS += $(shell $(PKG_CONFIG) fuse3 --cflags)
include $(BUILD_INC)/Makefile.inc
---- a/src/Driver/Fuse/FuseService.cpp 2021-10-07 03:51:22.964715592 -0400
-+++ b/src/Driver/Fuse/FuseService.cpp 2021-10-07 03:51:22.948715727 -0400
+--- a/src/Driver/Fuse/FuseService.cpp
++++ b/src/Driver/Fuse/FuseService.cpp
@@ -13,7 +13,7 @@
#ifdef TC_OPENBSD
#define FUSE_USE_VERSION 26
@@ -40,7 +40,7 @@ Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
#endif
#include <errno.h>
-@@ -56,11 +56,7 @@
+@@ -56,11 +56,7 @@ namespace VeraCrypt
return 0;
}
@@ -53,7 +53,7 @@ Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
{
try
{
-@@ -104,7 +100,7 @@
+@@ -104,7 +100,7 @@ namespace VeraCrypt
}
}
@@ -62,7 +62,7 @@ Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
{
try
{
-@@ -261,7 +257,7 @@
+@@ -261,7 +257,7 @@ namespace VeraCrypt
return -ENOENT;
}
@@ -71,7 +71,7 @@ Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
{
try
{
-@@ -271,10 +267,10 @@
+@@ -271,10 +267,10 @@ namespace VeraCrypt
if (strcmp (path, "/") != 0)
return -ENOENT;
@@ -86,7 +86,7 @@ Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
}
catch (...)
{
-@@ -450,7 +446,7 @@
+@@ -450,7 +446,7 @@ namespace VeraCrypt
}
ExecFunctor execFunctor (openVolume, slotNumber);
@@ -95,7 +95,7 @@ Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
for (int t = 0; true; t++)
{
-@@ -592,11 +588,7 @@
+@@ -592,11 +588,7 @@ namespace VeraCrypt
SignalHandlerPipe->GetWriteFD();
diff --git a/veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch b/veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch
new file mode 100644
index 0000000..9cd566f
--- /dev/null
+++ b/veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch
@@ -0,0 +1,33 @@
+From bd843ffa05147aab80e38ee668b0556302d2bfc9 Mon Sep 17 00:00:00 2001
+From: Mounir IDRASSI <mounir.idrassi@idrix.fr>
+Date: Mon, 2 Oct 2023 18:02:33 +0200
+Subject: [PATCH] Linux: Fix compilation error on some 32-bit machines.
+
+---
+ src/Common/PCSCException.cpp | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/Common/PCSCException.cpp b/src/Common/PCSCException.cpp
+index 93fff18187..dc5eead323 100644
+--- a/src/Common/PCSCException.cpp
++++ b/src/Common/PCSCException.cpp
+@@ -140,14 +140,17 @@ namespace VeraCrypt
+ {
+ Exception::Deserialize(stream);
+ Serializer sr(stream);
+- sr.Deserialize("ErrorCode", ErrorCode);
++ int64 v;
++ sr.Deserialize("ErrorCode", v);
++ ErrorCode = (LONG_PCSC)v;
+ }
+
+ void PCSCException::Serialize(shared_ptr <Stream> stream) const
+ {
+ Exception::Serialize(stream);
+ Serializer sr(stream);
+- sr.Serialize("ErrorCode", ErrorCode);
++ int64 v = (int64)ErrorCode;
++ sr.Serialize("ErrorCode", v);
+ }
+
+ # define TC_EXCEPTION(TYPE) TC_SERIALIZER_FACTORY_ADD(TYPE)
diff --git a/veracrypt/debian/patches/series b/veracrypt/debian/patches/series
index 8518785..831301f 100644
--- a/veracrypt/debian/patches/series
+++ b/veracrypt/debian/patches/series
@@ -1,2 +1,3 @@
1001-port-to-libfuse3.patch
+1002-fix-ftbfs-32bit.patch
vc_devuan.patch
diff --git a/veracrypt/debian/patches/vc_devuan.patch b/veracrypt/debian/patches/vc_devuan.patch
index 9ce5efb..386e777 100644
--- a/veracrypt/debian/patches/vc_devuan.patch
+++ b/veracrypt/debian/patches/vc_devuan.patch
@@ -1,21 +1,19 @@
-Version: 1.25.7
-Date: 2022-02-10
-diff -x '*.rej' -x '*.orig' -Naur VeraCrypt_1.22/src/Common/Dlgcode.c VeraCrypt_1.22-1/src/Common/Dlgcode.c
---- VeraCrypt_1.22/src/Common/Dlgcode.c 2018-03-30 07:54:10.000000000 -0400
-+++ VeraCrypt_1.22-1/src/Common/Dlgcode.c 2018-09-02 08:22:00.007030589 -0400
-@@ -1280,7 +1280,7 @@
+Version: 1.26.7
+Date: 2023-10-03
+--- a/src/Common/Dlgcode.c
++++ b/src/Common/Dlgcode.c
+@@ -2171,7 +2171,7 @@ BOOL CALLBACK AboutDlgProc (HWND hwndDlg
L"This software as a whole:\r\n"
- L"Copyright \xA9 2013-2022 IDRIX. All rights reserved.\r\n\r\n"
+ L"Copyright \xA9 2013-2023 IDRIX. All rights reserved.\r\n\r\n"
- L"An IDRIX Release");
+ L"Packaged for Devuan");
return 1;
-diff -x '*.rej' -x '*.orig' -Naur VeraCrypt_1.22/src/Common/Tcdefs.h VeraCrypt_1.22-1/src/Common/Tcdefs.h
---- VeraCrypt_1.22/src/Common/Tcdefs.h 2018-03-30 07:54:10.000000000 -0400
-+++ VeraCrypt_1.22-1/src/Common/Tcdefs.h 2018-09-02 08:23:02.200707158 -0400
-@@ -383,7 +383,7 @@
+--- a/src/Common/Tcdefs.h
++++ b/src/Common/Tcdefs.h
+@@ -447,7 +447,7 @@ void EraseMemory (void *memory, int size
#define TC_MAX_PATH 260 /* Includes the null terminator */
#endif
@@ -24,10 +22,9 @@ diff -x '*.rej' -x '*.orig' -Naur VeraCrypt_1.22/src/Common/Tcdefs.h VeraCrypt_1
#define MAX_URL_LENGTH 2084 /* Internet Explorer limit. Includes the terminating null character. */
-diff -x '*.rej' -x '*.orig' -Naur VeraCrypt_1.22/src/Main/Forms/AboutDialog.cpp VeraCrypt_1.22-1/src/Main/Forms/AboutDialog.cpp
---- VeraCrypt_1.22/src/Main/Forms/AboutDialog.cpp 2018-03-30 07:54:10.000000000 -0400
-+++ VeraCrypt_1.22-1/src/Main/Forms/AboutDialog.cpp 2018-09-02 08:23:41.447134097 -0400
-@@ -72,6 +72,6 @@
+--- a/src/Main/Forms/AboutDialog.cpp
++++ b/src/Main/Forms/AboutDialog.cpp
+@@ -74,6 +74,6 @@ namespace VeraCrypt
L"This software uses wxWidgets library, which is copyright \xA9 1998-2011 Julian Smart, Robert Roebling et al.\n\n"
diff --git a/veracrypt/debian/veracrypt+stackrpms.dsc b/veracrypt/debian/veracrypt+stackrpms.dsc
index 42e2364..18d28d3 100644
--- a/veracrypt/debian/veracrypt+stackrpms.dsc
+++ b/veracrypt/debian/veracrypt+stackrpms.dsc
@@ -2,7 +2,7 @@ Format: 3.0 (quilt)
Source: veracrypt
Binary: veracrypt
Architecture: any
-Version: 1.25.9-3+stackrpms
+Version: 1.26.7-1+stackrpms
Maintainer: B. Stack <bgstack15@gmail.com>
Homepage: https://veracrypt.fr/
Standards-Version: 4.6.0
bgstack15