summaryrefslogtreecommitdiff
path: root/ublock-origin-combined/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-10-20 14:14:07 -0400
committerB Stack <bgstack15@gmail.com>2020-10-20 14:14:07 -0400
commitec1b4def96f555245774ae843bdcafff58103168 (patch)
treeb7f982ca20c7f9a6f1d3129e587dd7c58f6202ff /ublock-origin-combined/debian/rules
parentMerge branch 'makemkv-bump' into 'master' (diff)
downloadstackrpms-ec1b4def96f555245774ae843bdcafff58103168.tar.gz
stackrpms-ec1b4def96f555245774ae843bdcafff58103168.tar.bz2
stackrpms-ec1b4def96f555245774ae843bdcafff58103168.zip
ublock-origin-combined rc1
First attempt in both rpm and dpkg for a single package that owns ublock-origin. This should simplify maintenance going forward.
Diffstat (limited to 'ublock-origin-combined/debian/rules')
-rwxr-xr-xublock-origin-combined/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/ublock-origin-combined/debian/rules b/ublock-origin-combined/debian/rules
new file mode 100755
index 0000000..f6069f7
--- /dev/null
+++ b/ublock-origin-combined/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export NAME=ublock-origin-combined
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make -e -f debian/Makefile install -- DESTDIR=debian/${NAME}
+
+#override_dh_auto_clean:
+# rm -rf debian/usr
bgstack15