summaryrefslogtreecommitdiff
path: root/ublock-origin-combined/debian/Makefile
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-10-26 23:26:44 +0000
committerB Stack <bgstack15@gmail.com>2020-10-26 23:26:44 +0000
commit0a613261d1c9148a29b710690c52c4402278179d (patch)
treef0e533070438b724b10b32445f703be4baec6623 /ublock-origin-combined/debian/Makefile
parentMerge branch 'makemkv-bump' into 'master' (diff)
parentremove deprecated packages for ubo-combined (diff)
downloadstackrpms-0a613261d1c9148a29b710690c52c4402278179d.tar.gz
stackrpms-0a613261d1c9148a29b710690c52c4402278179d.tar.bz2
stackrpms-0a613261d1c9148a29b710690c52c4402278179d.zip
Merge branch 'ublock-origin-bump' into 'master'
Ublock origin bump See merge request bgstack15/stackrpms!198
Diffstat (limited to 'ublock-origin-combined/debian/Makefile')
-rw-r--r--ublock-origin-combined/debian/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/ublock-origin-combined/debian/Makefile b/ublock-origin-combined/debian/Makefile
new file mode 100644
index 0000000..fca5b8a
--- /dev/null
+++ b/ublock-origin-combined/debian/Makefile
@@ -0,0 +1,19 @@
+# Makefile for palemoon-ublock-origin for devuan
+SOURCE0=uBlock0.firefox-legacy.xpi
+extdir1=/usr/lib/palemoon/browser/extensions
+extdir3=/usr/lib/waterfox/browser/extensions
+extdir4=/usr/lib/newmoon/browser/extensions
+
+# this needs to be overwritten by the debian/rules file.
+DESTDIR=/tmp
+
+install:
+ unzip ${SOURCE0} install.rdf
+ mkdir -p $(DESTDIR)${extdir1}
+ newfilename="$$( grep 'em:id' install.rdf 2>/dev/null | head -n1 | sed -r -e 's/^.*<em:id>//;' -e 's/<\/em:id>.*$$//;' ).xpi" ; \
+ test -z "$${newfilename}" && newfilename="$$( basename $${SOURCE0} )" ; \
+ install -Dp -m0644 ${SOURCE0} $(DESTDIR)${extdir1}/$${newfilename}
+ rm -f install.rdf || :
+
+uninstall:
+ rm -f $(DESTDIR)${extdir1}/uBlock0@raymondhill.net.xpi
bgstack15