summaryrefslogtreecommitdiff
path: root/puddletag/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-09-05 15:13:14 -0400
committerB Stack <bgstack15@gmail.com>2020-09-05 15:13:14 -0400
commitf3f2f01f396c6216fd4541f12d276c2e30f6de1b (patch)
tree06c5529edbef9c795134b0babf82879a092b8e14 /puddletag/debian/rules
parentWIP: add puddletag for py3 (diff)
downloadstackrpms-f3f2f01f396c6216fd4541f12d276c2e30f6de1b.tar.gz
stackrpms-f3f2f01f396c6216fd4541f12d276c2e30f6de1b.tar.bz2
stackrpms-f3f2f01f396c6216fd4541f12d276c2e30f6de1b.zip
initial work on py3+qt5
This builds an installable dpkg, but only for compat=11
Diffstat (limited to 'puddletag/debian/rules')
-rwxr-xr-xpuddletag/debian/rules20
1 files changed, 4 insertions, 16 deletions
diff --git a/puddletag/debian/rules b/puddletag/debian/rules
index f253703..9e5fa22 100755
--- a/puddletag/debian/rules
+++ b/puddletag/debian/rules
@@ -10,26 +10,14 @@
#export DH_VERBOSE=1
%:
- dh $@ --with python3,sphinxdoc
-
-override_dh_clean:
- dh_clean
- $(MAKE) -C puddletag-docs clean
+ dh $@ --with python3
override_dh_auto_install:
cd $(CURDIR)/source ; \
- python3 setup.py install --root=$(CURDIR)/debian/puddletag-py3 --install-layout=deb
-
- $(MAKE) -C puddletag-docs documentation SPHINXBUILD=sphinx-build
-
-override_dh_installdocs:
- dh_installdocs README.rst source/THANKS source/TODO
- mv puddletag-docs/_build/documentation/ puddletag-docs/_build/html/
- dh_installdocs puddletag-docs/_build/html/
- dh_link /usr/share/doc/puddletag/html/docs.html /usr/share/doc/puddletag/html/index.html
+ python3 setup.py install --root=$(CURDIR)/debian/puddletag --install-layout=deb
override_dh_compress:
dh_compress -X.txt
-override_dh_installchangelogs:
- dh_installchangelogs source/changelog
+#override_dh_installchangelogs:
+# dh_installchangelogs source/changelog
bgstack15