summaryrefslogtreecommitdiff
path: root/powerkit/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-04-06 15:38:12 -0400
committerB Stack <bgstack15@gmail.com>2020-04-06 15:38:12 -0400
commita7fbd829a2dbe3164629acd03197858176e817c3 (patch)
tree60e6427f669078900e216cccb8867a0213824336 /powerkit/debian/rules
parentMerge branch 'palemoon-bump' into 'master' (diff)
downloadstackrpms-a7fbd829a2dbe3164629acd03197858176e817c3.tar.gz
stackrpms-a7fbd829a2dbe3164629acd03197858176e817c3.tar.bz2
stackrpms-a7fbd829a2dbe3164629acd03197858176e817c3.zip
add powerkit 1.0.0
Diffstat (limited to 'powerkit/debian/rules')
-rwxr-xr-xpowerkit/debian/rules36
1 files changed, 36 insertions, 0 deletions
diff --git a/powerkit/debian/rules b/powerkit/debian/rules
new file mode 100755
index 0000000..0046dad
--- /dev/null
+++ b/powerkit/debian/rules
@@ -0,0 +1,36 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+# Reference:
+# qmake options examples https://github.com/bertogg/gallery-liquify-plugin/blob/73e0034f545f9092b42d7045e7ba9abd61fb0374/debian/rules
+# for multi-package split https://salsa.debian.org/xorg-team/lib/libxss/-/tree/debian-unstable/debian
+# this app build options https://gitlab.com/rodlie/powerkit
+# use ${LIBSUFFIX} this app lib/lib.pro
+
+export APPNAME=powerkit
+
+QMAKE_OPTIONS += QMAKE_CXXFLAGS_RELEASE='$(CFLAGS)' \
+ QMAKE_CXXFLAGS_DEBUG='$(CFLAGS)' \
+ QMAKE_CFLAGS_RELEASE='$(CFLAGS)' \
+ QMAKE_CFLAGS_DEBUG='$(CFLAGS)' \
+ QMAKE_STRIP=: \
+ PREFIX=/usr \
+ UDEVDIR=/lib/udev \
+ CONFIG+=install_udev_rules \
+ CONFIG+=install_lib \
+ LIBSUFFIX=/${DEB_HOST_MULTIARCH}
+# if you want to build with bundled icons:
+ #CONFIG+=bundle_icons
+
+%:
+ dh $@ --buildsystem=qmake
+
+override_dh_auto_configure:
+ qmake $(QMAKE_OPTIONS)
+
+override_dh_auto_build:
+ dh_auto_build
+ sh debian/make-dsc-for-obs.sh
bgstack15