summaryrefslogtreecommitdiff
path: root/palemoon/debian
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-07-26 15:22:13 -0400
committerB Stack <bgstack15@gmail.com>2020-07-26 15:22:13 -0400
commit51735f7a03d9f1e83ed3410b0174dd07ce63b4bb (patch)
tree9789776d074366c228e4609182de144c169ffaef /palemoon/debian
parentadjust mozconfig again (diff)
downloadstackrpms-51735f7a03d9f1e83ed3410b0174dd07ce63b4bb.tar.gz
stackrpms-51735f7a03d9f1e83ed3410b0174dd07ce63b4bb.tar.bz2
stackrpms-51735f7a03d9f1e83ed3410b0174dd07ce63b4bb.zip
try export MOZCONFIG in d/rules
Diffstat (limited to 'palemoon/debian')
-rw-r--r--palemoon/debian/mozconfig9
-rw-r--r--palemoon/debian/mozconfig-unstable55
-rwxr-xr-xpalemoon/debian/rules9
3 files changed, 63 insertions, 10 deletions
diff --git a/palemoon/debian/mozconfig b/palemoon/debian/mozconfig
index 89b2796..445c209 100644
--- a/palemoon/debian/mozconfig
+++ b/palemoon/debian/mozconfig
@@ -1,9 +1,3 @@
-if test `lsb_release -sc` = "sid" || test `lsb_release -sc` = "unstable" ; then
-export JCOUNT=1
-else
-export JCOUNT=4
-fi
-
mk_add_options AUTOCLOBBER=1
export BUILDING_RELEASE=1
export MC_OFFICIAL=1
@@ -56,4 +50,5 @@ ac_add_options --enable-alsa
# primarily for 32-bit but tolerated for 64-bit
ac_add_options --x-libraries=/usr/lib
-mk_add_options MOZ_MAKE_FLAGS=-j${JCOUNT}
+# limit to 4 cpus to limit memory usage (approximately 0.75 GiB RAM/thread)
+mk_add_options MOZ_MAKE_FLAGS="-j4"
diff --git a/palemoon/debian/mozconfig-unstable b/palemoon/debian/mozconfig-unstable
new file mode 100644
index 0000000..aa04e06
--- /dev/null
+++ b/palemoon/debian/mozconfig-unstable
@@ -0,0 +1,55 @@
+mk_add_options AUTOCLOBBER=1
+export BUILDING_RELEASE=1
+export MC_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MC_PALEMOON=1
+
+#mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/pmbuild
+
+ac_add_options --enable-application=palemoon
+ac_add_options --enable-official-branding
+ac_add_options --enable-official-vendor
+
+# Disable add-ons signing
+# Disable checking that add-ons are signed by the trusted root
+MOZ_ADDON_SIGNING=
+# Disable enforcing that add-ons are signed by the trusted root
+MOZ_REQUIRE_SIGNING=
+
+# Standard
+# Enables
+ac_add_options --enable-av1
+ac_add_options --enable-optimize="-O2 -Wl,--no-keep-memory -Wl,--reduce-memory-overhead"
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --enable-devtools
+ac_add_options --enable-jemalloc
+ac_add_options --with-pthreads
+ac_add_options --enable-strip
+# Disables
+ac_add_options --disable-debug
+ac_add_options --disable-eme
+ac_add_options --disable-gamepad
+ac_add_options --disable-necko-wifi
+ac_add_options --disable-tests
+ac_add_options --disable-updater
+ac_add_options --disable-webrtc
+# Disable temeletry
+export MOZ_TELEMETRY_REPORTING=
+ac_add_options --disable-crashreporter
+ac_add_options --disable-parental-controls
+ac_add_options --disable-accessibility
+
+# Debian style
+ac_add_options --prefix=/usr
+# Devuan style
+ac_add_options --disable-dbus
+ac_add_options --disable-pulseaudio
+# even though this is redundant
+ac_add_options --enable-alsa
+
+# primarily for 32-bit but tolerated for 64-bit
+ac_add_options --x-libraries=/usr/lib
+
+# limit to 4 cpus to limit memory usage (approximately 0.75 GiB RAM/thread)
+# single-threaded for Devuan unstable
+mk_add_options MOZ_MAKE_FLAGS="-j1"
diff --git a/palemoon/debian/rules b/palemoon/debian/rules
index d970f5e..0a5c388 100755
--- a/palemoon/debian/rules
+++ b/palemoon/debian/rules
@@ -13,6 +13,12 @@ export SHELL=/bin/bash
#export LD=gcc-8
#endif
+export MOZCONFIG=debian/mozconfig
+distrelease := $(shell lsb_release -cs)
+ifeq ($(distrelease),$(filter $(distrelease),sid unstable ceres))
+export MOZCONFIG=debian/mozconfig-unstable
+endif
+
%:
dh $@
@@ -21,9 +27,6 @@ override_dh_auto_clean:
dh_auto_clean
find . -name '*.pyc' -delete
-override_dh_auto_configure:
- cp debian/mozconfig mozconfig
-
override_dh_auto_build:
make -f client.mk build
bgstack15