summaryrefslogtreecommitdiff
path: root/palemoon-ublock-origin/debian/Makefile
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-02-14 10:27:46 -0500
committerB Stack <bgstack15@gmail.com>2019-02-14 10:27:46 -0500
commit4ecfc656e6bc4719cac235025a104f935f9112fc (patch)
treefb95954405761b3ad091397c1c8741be8ed1255b /palemoon-ublock-origin/debian/Makefile
parentpm ublock origin 1.16.4.8 (diff)
downloadstackrpms-4ecfc656e6bc4719cac235025a104f935f9112fc.tar.gz
stackrpms-4ecfc656e6bc4719cac235025a104f935f9112fc.tar.bz2
stackrpms-4ecfc656e6bc4719cac235025a104f935f9112fc.zip
pm-ublock dpkg for devuan
Diffstat (limited to 'palemoon-ublock-origin/debian/Makefile')
-rw-r--r--palemoon-ublock-origin/debian/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/palemoon-ublock-origin/debian/Makefile b/palemoon-ublock-origin/debian/Makefile
new file mode 100644
index 0000000..3531a3e
--- /dev/null
+++ b/palemoon-ublock-origin/debian/Makefile
@@ -0,0 +1,17 @@
+# Makefile for palemoon-ublock-origin for devuan
+SOURCE0=uBlock0.firefox-legacy.xpi
+MOZ_EXTENSIONS=/usr/lib/palemoon/browser/extensions
+
+# this needs to be overwritten by the debian/rules file.
+DESTDIR=/tmp
+
+install:
+ unzip ${SOURCE0} install.rdf
+ mkdir -p $(DESTDIR)${MOZ_EXTENSIONS}
+ newfilename="$$( grep 'em:id' install.rdf 2>/dev/null | head -n1 | sed -r -e 's/^.*<em:id>//;' -e 's/<\/em:id>.*$$//;' ).xpi" ; \
+ test -z "$${newfilename}" && newfilename="$$( basename $${SOURCE0} )" ; \
+ install -Dp -m0644 ${SOURCE0} $(DESTDIR)${MOZ_EXTENSIONS}/$${newfilename}
+ rm -f install.rdf || :
+
+uninstall:
+ rm -f $(DESTDIR)${MOZ_EXTENSIONS}/uBlock0@raymondhill.net.xpi
bgstack15