summaryrefslogtreecommitdiff
path: root/palemoon-stackrpms-ublock-origin/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-02-19 14:11:17 -0500
committerB Stack <bgstack15@gmail.com>2019-02-19 14:11:17 -0500
commitc033cdd7200d654ada811d9ef769de96a7c87b0b (patch)
treee3b0ba772fa2d5b0ad3e601126eae22998dcbaaf /palemoon-stackrpms-ublock-origin/debian/rules
parentrename pm-stack-ublock spec (diff)
downloadstackrpms-c033cdd7200d654ada811d9ef769de96a7c87b0b.tar.gz
stackrpms-c033cdd7200d654ada811d9ef769de96a7c87b0b.tar.bz2
stackrpms-c033cdd7200d654ada811d9ef769de96a7c87b0b.zip
split pm-ublock into two dirs
Diffstat (limited to 'palemoon-stackrpms-ublock-origin/debian/rules')
-rwxr-xr-xpalemoon-stackrpms-ublock-origin/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/palemoon-stackrpms-ublock-origin/debian/rules b/palemoon-stackrpms-ublock-origin/debian/rules
new file mode 100755
index 0000000..cc4c963
--- /dev/null
+++ b/palemoon-stackrpms-ublock-origin/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export NAME=palemoon-ublock-origin
+export MOZ_EXTENSIONS=/usr/lib/palemoon/browser/extensions
+export SOURCE0=uBlock0.firefox-legacy.xpi
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make -e -f debian/Makefile install -- DESTDIR=debian/${NAME}
+
+#override_dh_auto_clean:
+# rm -rf debian/usr
bgstack15