summaryrefslogtreecommitdiff
path: root/palemoon-stackrpms-ublock-origin/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-02-19 20:26:48 +0000
committerB Stack <bgstack15@gmail.com>2019-02-19 20:26:48 +0000
commit4074c453512f3ba416902f649468b4e3a5c668da (patch)
tree296947512a43536121f97b588a5574668d399ff1 /palemoon-stackrpms-ublock-origin/debian/rules
parentMerge branch 'freefilesync-c7' into 'master' (diff)
parentsplit pm-ublock into two dirs (diff)
downloadstackrpms-4074c453512f3ba416902f649468b4e3a5c668da.tar.gz
stackrpms-4074c453512f3ba416902f649468b4e3a5c668da.tar.bz2
stackrpms-4074c453512f3ba416902f649468b4e3a5c668da.zip
Merge branch 'palemoon-custom' into 'master'
Multiple palemoon builds Split palemoon into official package, and my custom -stackrpms package. Also split palemoon-ublock-origin in same way. Update palemoon to 28.4.0. See merge request bgstack15/stackrpms!39
Diffstat (limited to 'palemoon-stackrpms-ublock-origin/debian/rules')
-rwxr-xr-xpalemoon-stackrpms-ublock-origin/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/palemoon-stackrpms-ublock-origin/debian/rules b/palemoon-stackrpms-ublock-origin/debian/rules
new file mode 100755
index 0000000..cc4c963
--- /dev/null
+++ b/palemoon-stackrpms-ublock-origin/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export NAME=palemoon-ublock-origin
+export MOZ_EXTENSIONS=/usr/lib/palemoon/browser/extensions
+export SOURCE0=uBlock0.firefox-legacy.xpi
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make -e -f debian/Makefile install -- DESTDIR=debian/${NAME}
+
+#override_dh_auto_clean:
+# rm -rf debian/usr
bgstack15