summaryrefslogtreecommitdiff
path: root/onedrive/onedrive.spec
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-05-31 09:35:06 -0400
committerB Stack <bgstack15@gmail.com>2019-05-31 09:35:06 -0400
commit5169937276a6eab250eef20b81e8c4b48fe2c8d1 (patch)
treec2236dbc7d807e11e4d14a1bf8318c39a4131fbb /onedrive/onedrive.spec
parentMerge branch 'waterfox-bump' into 'master' (diff)
downloadstackrpms-5169937276a6eab250eef20b81e8c4b48fe2c8d1.tar.gz
stackrpms-5169937276a6eab250eef20b81e8c4b48fe2c8d1.tar.bz2
stackrpms-5169937276a6eab250eef20b81e8c4b48fe2c8d1.zip
add onedrive experimental spec
Diffstat (limited to 'onedrive/onedrive.spec')
-rw-r--r--onedrive/onedrive.spec56
1 files changed, 56 insertions, 0 deletions
diff --git a/onedrive/onedrive.spec b/onedrive/onedrive.spec
new file mode 100644
index 0000000..8826dcf
--- /dev/null
+++ b/onedrive/onedrive.spec
@@ -0,0 +1,56 @@
+%define debug_package %{nil}
+
+Summary: A complete tool to interact with OneDrive on Linux. Built following the UNIX philosophy.
+Name: onedrive
+Version: 2.3.3
+Release: 1
+Source: https://github.com/abraunegg/%{name}/archive/v%{version}.tar.gz
+License: GPL-3
+Group: System Environment/Daemons
+# on el7, get ldc from copr://harbottle/main
+BuildRequires: ldc
+BuildRequires: gcc
+BuildRequires: sqlite-devel
+BuildRequires: libcurl-devel
+Requires: libcurl
+Requires: sqlite
+Requires(post): systemd
+Requires(preun): systemd
+
+%description
+A complete tool to interact with OneDrive on Linux. Built following the UNIX philosophy.
+
+%prep
+%setup
+#%patch0 -p0
+
+%build
+make DC=ldc2 PREFIX=/usr/ DESTDIR=$RPM_BUILD_ROOT all
+
+%install
+mkdir -p %{buildroot}/usr/bin
+install -D onedrive %{buildroot}/usr/bin/onedrive
+install -D -m 644 onedrive.service %{buildroot}/usr/lib/systemd/user/onedrive.service
+
+%files
+%doc CHANGELOG.md README.md config
+%license LICENSE
+%defattr(-,root,root)
+%attr(0555,bin,bin) /usr/bin/onedrive
+%attr(0555,bin,bin) /usr/lib/systemd/user/onedrive.service
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%changelog
+* Fri May 31 2019 B Stack <bgstack15@gmail.com> - 2.3.3-1
+- move to abraunegg distrubtion of onedrive client from skillion
+
+* Sat Feb 10 2018 Patrick Pichon <patrick@pichon.me>
+add config file, and few addition prerequisites
+
+* Fri Feb 9 2018 Patrick Pichon <patrick@pichon.me>
+ready for Copr
+
+* Thu Feb 8 2018 Patrick Pichon <patrick@pichon.me>
+initial version
bgstack15