summaryrefslogtreecommitdiff
path: root/newmoon/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-09-16 20:16:42 -0400
committerB Stack <bgstack15@gmail.com>2020-09-16 20:16:42 -0400
commitf003ff9961df2d31730a26c5f0bffc2025b53403 (patch)
tree1696bf12655f5b08c4fcc6704015ec5d54c9e5be /newmoon/debian/rules
parentadd xfce helper to newmoon (diff)
downloadstackrpms-f003ff9961df2d31730a26c5f0bffc2025b53403.tar.gz
stackrpms-f003ff9961df2d31730a26c5f0bffc2025b53403.tar.bz2
stackrpms-f003ff9961df2d31730a26c5f0bffc2025b53403.zip
add bluemoon icons
This prepares newmoon with the ability to be branded bluemoon to further separate it from even the off-brand palemoon brand. Icons provided by Gord N. Squash.
Diffstat (limited to 'newmoon/debian/rules')
-rwxr-xr-xnewmoon/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/newmoon/debian/rules b/newmoon/debian/rules
index 461d685..230114f 100755
--- a/newmoon/debian/rules
+++ b/newmoon/debian/rules
@@ -22,9 +22,16 @@ override_dh_auto_clean:
rm -f mozconfig
dh_auto_clean
find . -name '*.pyc' -delete
+ test -d palemoon/branding/unofficial.unbuilt && { \
+ rm -rf palemoon/branding/unofficial palemoon/branding/*.blue* ; \
+ mv palemoon/branding/unofficial.unbuilt palemoon/branding/unofficial ; \
+ } || :
override_dh_auto_configure:
cp ${MCFILE} mozconfig
+ ! test -d palemoon/branding/unofficial.unbuilt && { \
+ cp -pr palemoon/branding/unofficial palemoon/branding/unofficial.unbuilt && \
+ tar -C palemoon/branding -zxf debian/bluemoon-icons.tgz ; } || :
override_dh_auto_build:
make -f client.mk build ENABLE_STRIP=1
bgstack15