summaryrefslogtreecommitdiff
path: root/move-to-next-monitor/move-to-next-monitor.spec
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2018-11-30 15:20:29 -0500
committerB Stack <bgstack15@gmail.com>2018-11-30 15:20:29 -0500
commitdc81fab796e6e7a288b5db89fda9f09d9d4a00aa (patch)
tree7847d3a8c2cd66d32c3e0dbf12b9eeabbe2f2e86 /move-to-next-monitor/move-to-next-monitor.spec
parentMerge branch 'wxgtk3-bump' into 'master' (diff)
downloadstackrpms-dc81fab796e6e7a288b5db89fda9f09d9d4a00aa.tar.gz
stackrpms-dc81fab796e6e7a288b5db89fda9f09d9d4a00aa.tar.bz2
stackrpms-dc81fab796e6e7a288b5db89fda9f09d9d4a00aa.zip
add move-to-next-monitor
Diffstat (limited to 'move-to-next-monitor/move-to-next-monitor.spec')
-rw-r--r--move-to-next-monitor/move-to-next-monitor.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/move-to-next-monitor/move-to-next-monitor.spec b/move-to-next-monitor/move-to-next-monitor.spec
new file mode 100644
index 0000000..446cb0b
--- /dev/null
+++ b/move-to-next-monitor/move-to-next-monitor.spec
@@ -0,0 +1,89 @@
+%global dummy_package 0
+%global use_git 1
+%if 0%{use_git}
+%global tarballdir %{name}-master
+%else
+%global tarballdir %{name}-%{version}
+%endif
+%define license_files %{srcdir}/License.txt
+
+# turn off debug package
+%define debug_package %{nil}
+
+Name: move-to-next-monitor
+Version: 0.0.1
+Release: 1
+BuildArch: noarch
+Summary: Script that facilitates moving a window to the next monitor
+
+Group: Utility
+License: GPL-3.0
+URL: https://gitlab.com/bgstack15/move-to-next-monitor
+%if 0%{use_git}
+# Source0: https://github.com/vanaoff/move-to-next-monitor/archive/master.zip
+Source0: https://gitlab.com/bgstack15/%{name}/-/archive/master/%{name}-master.tar.gz
+%else
+Source0: https://gitlab.com/bgstack15/%{name}/-/archive/%{version}/%{name}-master.tar.gz
+%endif
+Source1: move-to-next-monitor.Makefile
+Source2: README.md
+#Patch1: none.patch
+
+Packager: Bgstack15 <bgstack15@gmail.com>
+BuildRequires: coreutils
+Requires: python3
+Requires: wmctrl
+Requires: xdotool
+Requires: xorg-x11-server-utils
+Requires: xorg-x11-utils
+
+%description
+move-to-next-monitor is a small script that makes it easy for display managers without this native functionality to provide it. You can assign a shortcut key in the display manager settings to the script to use it.
+
+%prep
+%setup -q -c
+# copy in custom Makefile and adjust to use tarball directory as source directory
+%{__cp} -p %{SOURCE1} ./Makefile
+%{__sed} -i -r -e '/^SRCDIR\s*=/s:\$\(CURDIR\)\s*$:$(CURDIR)/'"%{tarballdir}"':;' ./Makefile
+
+#pushd %{tarballdir}
+#%patch0 -p1
+#popd
+
+%build
+:
+
+%install
+%make_install
+
+# man page
+%{__mkdir_p} %{buildroot}%{_pkgdocdir}
+%{__cp} -p "%{SOURCE2}" %{buildroot}%{_pkgdocdir}/
+
+%clean
+%{__rm} -rf %{buildroot} || :
+
+%post
+:
+
+%preun
+# is it a final removal?
+#if test "$1" = "0" ;
+#then
+#fi
+:
+
+%postun
+:
+
+%posttrans
+:
+
+%files
+%license LICENSE
+%doc %{_pkgdocdir}/*
+%{_bindir}/%{name}
+
+%changelog
+* Fri Nov 30 2018 B Stack <bgstack15@gmail.com> 0.0.1-1
+- initial package built
bgstack15