summaryrefslogtreecommitdiff
path: root/move-to-next-monitor/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-03-06 12:48:10 +0000
committerB Stack <bgstack15@gmail.com>2019-03-06 12:48:10 +0000
commitd9d11590ec541675670660c2700b44c0ffd0eb9b (patch)
tree36c9af80709f6137afc8fd3a050edef55bc28583 /move-to-next-monitor/debian/rules
parentMerge branch 'irfanview-dpkg' into 'master' (diff)
parentdpkg for move-to-next-monitor (diff)
downloadstackrpms-d9d11590ec541675670660c2700b44c0ffd0eb9b.tar.gz
stackrpms-d9d11590ec541675670660c2700b44c0ffd0eb9b.tar.bz2
stackrpms-d9d11590ec541675670660c2700b44c0ffd0eb9b.zip
Merge branch 'move-dpkg' into 'master'
dpkg for move-to-next-monitor See merge request bgstack15/stackrpms!45
Diffstat (limited to 'move-to-next-monitor/debian/rules')
-rwxr-xr-xmove-to-next-monitor/debian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/move-to-next-monitor/debian/rules b/move-to-next-monitor/debian/rules
new file mode 100755
index 0000000..d127e1e
--- /dev/null
+++ b/move-to-next-monitor/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export name=move-to-next-monitor
+export version=0.0.1
+
+export use_git=1
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ # technically redundant as there is no compilation
+ make -f debian/move-to-next-monitor.Makefile
+
+override_dh_auto_install:
+ make -f debian/move-to-next-monitor.Makefile install -- DESTDIR=debian/${name}
bgstack15